Port replicator displays flickering off and on

CELVIN NAS, Storagebird, Memorybird, Keyboards, WebCam, etc.

Moderator: ModTeam

adamcannon
Posts: 1
Joined: Wed May 02, 2018 15:54
Product(s): Lifebook ME15A

Port replicator displays flickering off and on

Postby adamcannon » Mon Aug 13, 2018 15:54

Hi,

I have Fujitsu lifebook E558 connected to a Fujitsu port replicator product number FPCPR363. My problem is that any external monitor connected to either display port flickers briefly off and then on for about a second at random points during the day.

Sometimes it's every minute or so, other times hours will go by before either of the monitors suddenly goes blank and then comes back up a second or so later. If using duel displays, one in the DVI port and another in the VGA port, then sometimes shortly after one screen going blank, the other will do the same. If using a single display, in either the VGA or DVI port the issue also occurs.

If the external displays are connected directly to the laptop's external ports then there are no problems.

My colleague working besides me with the exact same laptop and port replicator combination, but two completely different models of monitor has the same problem as myself. However my manager, also using the same combination of laptop and port replicator, experiences no issues.

My manager's port replicator is the exact same make and model is my own, so from the hardware side I can't see why hers would be fine and my colleagues would not. I have updated all display drivers and I'm contemplating updating the laptop's BIOS to see if this would resolve it.

I'm wondering if anybody else has experianced this issue and what you have done to resolve it?

Return to “Accessories”

Who is online

Users browsing this forum: No registered users and 0 guests