[V2010] Keyboard problem

Moderator: ModTeam

pro2010
Posts: 4
Joined: Sat Jun 16, 2012 18:54
Product(s): Laptop Amilo Pro V2010

[V2010] Keyboard problem

Postby pro2010 » Fri Jun 22, 2012 19:12

I have Amilo Pro V2010 for a long period of time. It did work very good, it was very stable and reliable.

But recently, few issues appeared.

First issue:
Left speaker not working. On headphones - everything is okay, the problem is related to speaker only. It may be problem with some mechanism which is turning off speakers when headphones are physically connected but I cannot be sure.

Second issue:
Network card does not work. I tried cleaning, very carefully, there was some dust. It did not help. I put PCMCIA network card and - have network again. Not a perfect solution, it is more a workaround, but it works.

Third issue:
Problem - one key on keyboard - arrow down key.

It cannot be used (pressing the arrow down is not producing any result), and after some period of time, after the laptop is started - sometimes immediately - it is behaving like - the arrow down is pressed all the time (for example in Windows Explorer, current object is moving down, in Internet Explorer content of the windows is scrolling down - when arrow up is pressed it stops, but starts again after 10 seconds, a minute, sometimes more time). So it is not usable - pressing the key has no result, but it behaves like it is already pressed (circuit is closed).

I tried to clean the keyboard with compressed air duster, I removed the keyboard from laptop, carefully used compressed air to clean the space between keys (I did not remove keys - I tried to clean it just removing dust from space between keys, and inside the laptop - below metal protection).

Somehow, it helped a bit, for very short period of time, I was even able to press the arrow down few times with normal response for the key, but after that - everything was as it was - problem appeared again. I cannot be sure if compressed air duster helped just because it lowered the temperature inside the laptop and / or at the keyboard.

I did not cut keyboard ribbon connector what some users sometimes do (cut one or two millimeters of ribbon) to try to solve similar problem.

Then I removed all 4 cursor arrows keys, also those black plastic parts and rubbers, and clean the space between plastic film (there are more film layers, I cleaned all) carefully.

It did not help.

Now, I have to ask if somebody may provide answers - did anybody have the same or similar issue?

Questions for Fujitsu - please, is there a possibility to provide details.

1. What may be the issue with left speaker? Or, maybe, more possible issues? How to remedy?

2. Is there a possibility to check what happened to internal network card? How to resolve the problem, if possible?

3. Where is the origin of the keyboard problem (I tried to explain all details what happened in number of details). Would be good if there would be some schematic picture of the keyboard film layers, so it would be possible to see where down arrow key has problem.


Thank you.

Return to “AMILO Pro”

Who is online

Users browsing this forum: No registered users and 0 guests