Amilo Xa 2528 CMOS battery

Moderator: ModTeam

PNeel
Posts: 4
Joined: Fri Oct 18, 2013 13:42
Product(s): Amilo XA 2528

Amilo Xa 2528 CMOS battery

Postby PNeel » Mon Oct 21, 2013 21:08

Hi

New to this forum.

Since a few weeks i need to keep setting the time and date on my laptop.

Now im not new to pc's and laptops but i cant seem to find the location of the CMOS battery, cause i think it dies hence why i need to keep setting the date/time correct.

Can some1 point me in the right location. Either im not looking good enough or the total back cover needs to be removed.

Txs

User avatar
sabrex
Posts: 1145
Joined: Thu Jun 05, 2003 0:01
Product(s): Various
Location: England
Contact:

Re: Amilo Xa 2528 CMOS battery

Postby sabrex » Tue Oct 22, 2013 9:06

Cant remember but its possibly to the left of the cpu. remove the service panel underneath. You would have to remove the cpu heatsink. I think it has a black tape covering over it. After replacing you will need some new thermal paste for cpu make sure you clean off all the old before re-applying.
You only need a pee size of thermal paste too much and it will have an opposite effect.

PNeel
Posts: 4
Joined: Fri Oct 18, 2013 13:42
Product(s): Amilo XA 2528

Re: Amilo Xa 2528 CMOS battery

Postby PNeel » Sat Oct 26, 2013 21:00

Txs for the advise. I'll check it this monday, let u know wether its the correct spot or not :P

PNeel
Posts: 4
Joined: Fri Oct 18, 2013 13:42
Product(s): Amilo XA 2528

Re: Amilo Xa 2528 CMOS battery

Postby PNeel » Tue Oct 29, 2013 22:23

Ok

Checked it. Wasn't in that spot u referred to me.

Seems its on the right side of the CPU, no need to take off the heatsink.

But (see picture) the CMOS battery is wired with a connector. The connector sits under the cover to the right which i can't seem to remove.

Any suggestions?
Attachments
IMG-20131029-WA0003.jpg
IMG-20131029-WA0003.jpg (15.68 KiB) Viewed 6703 times

PNeel
Posts: 4
Joined: Fri Oct 18, 2013 13:42
Product(s): Amilo XA 2528

Re: Amilo Xa 2528 CMOS battery

Postby PNeel » Sat Nov 02, 2013 17:35

Fixed it, connected (soldered) a new battery to the wires and put some ducktape around it, problem solved :)


Return to “AMILO Notebook”

Who is online

Users browsing this forum: No registered users and 1 guest