Amilo Li1818 - no WLan driver

Moderator: ModTeam

pjohnpope
Posts: 5
Joined: Thu Mar 01, 2012 22:33
Product(s): Amilo Li1818

Amilo Li1818 - no WLan driver

Postby pjohnpope » Fri Mar 02, 2012 14:50

Following problems with corrupt system files, and not being a great fan of Vista home edition, I formatted my hard drive and then installed Windows 7 Ultimate. I know it's not supported, but I also know people have done this successfully.

Everything works well except that my machine does not know it has a WLan. Device Manager shows only the ethernet connection under Network Adapters - there is an Unknown Device listed under Other devices.

Simple attempts to run driver updates don't help - not surprising I suppose if it doesn't know what the device is.

Please please can somebody point me at the download I need, and tell me how to install it?

User avatar
sabrex
Posts: 1145
Joined: Thu Jun 05, 2003 0:01
Product(s): Various
Location: England
Contact:

Re: Amilo Li1818 - no WLan driver

Postby sabrex » Wed Mar 07, 2012 14:55

64 bit or 32 bit
have you tried to force install via device manager

download WLAN miniCard D2301 & USB D1705 from driver download site @ fujitsu.
Extract zip to its own folder
Goto device manager and double click Unknown Device
Driver tab- Update driver -> Browse computer and point it at the folder you extracted (it should install as there are 2 .inf files in there)

pjohnpope
Posts: 5
Joined: Thu Mar 01, 2012 22:33
Product(s): Amilo Li1818

Re: Amilo Li1818 - no WLan driver

Postby pjohnpope » Wed Mar 07, 2012 19:45

That seemed to work, (but I had to download Vista driver, as there is no W7 driver) and device manager, under network adapters, now shows "Fujitsu Siemens Computers WLAN 802.11b/g(SiS163u)".
When I click on this the normal box opens up, which under the "general" tab tells me that "the device is working properly".

However, when I try to connect to my BT homehub (which this machine used to connect to perfectly before I upgraded to W7) it can see the network (and shows its proper name of BTHomeHub2-xxxx) but fails to connect.

Can I be certain, from the apparently successful instal, that I really have a D2301? FJ were unable to tell me, from the machine serial number, if I had this or an Intel 3945ABG.

User avatar
sabrex
Posts: 1145
Joined: Thu Jun 05, 2003 0:01
Product(s): Various
Location: England
Contact:

Re: Amilo Li1818 - no WLan driver

Postby sabrex » Thu Mar 08, 2012 9:31

pjohnpope wrote:Can I be certain, from the apparently successful instal, that I really have a D2301? FJ were unable to tell me, from the machine serial number, if I had this or an Intel 3945ABG.


Its very difficult to install the wrong wlan driver to the wrong componant. Since it installed its safe to say you have the right D2301. Now try going into device manager - doubling click the wlan and update driver - search internet and see if windows 7 picks up a later driver.

the good news is you can see available networks. when you connect does it at least ask you for authentication key ?

pjohnpope
Posts: 5
Joined: Thu Mar 01, 2012 22:33
Product(s): Amilo Li1818

Re: Amilo Li1818 - no WLan driver

Postby pjohnpope » Thu Mar 08, 2012 9:49

thanks for your help so far

ran driver update, and got the message that the driver was up to date.

Yes, it does ask for the wireless key - (which I am sure I entered correctly from the plastic card that came with the HomeHub. Visitors to the house happily connect using this key).

User avatar
sabrex
Posts: 1145
Joined: Thu Jun 05, 2003 0:01
Product(s): Various
Location: England
Contact:

Re: Amilo Li1818 - no WLan driver

Postby sabrex » Thu Mar 08, 2012 13:08

Ok wlan is ok you have 2 way communication established - wlan goes hello to router
Router then goes hello back but who are you? Enter key to access.

Any failure beyond that could be channel setting (should be 6) , Firewall related blocking (ie:norton internet security)
Your almost there.... :mrgreen:

pjohnpope
Posts: 5
Joined: Thu Mar 01, 2012 22:33
Product(s): Amilo Li1818

Re: Amilo Li1818 - no WLan driver

Postby pjohnpope » Thu Mar 08, 2012 18:36

the good use is that it really does work - went to the tennis club and connected to their network (after inputting relevant key, and doing ipconfig /release /renew because I had only hibernated my machine)

Bad news is that I still can't make wireless connect to my own BT Homehub, which is clearly working as I can connect to it with direct cable, and my wife's notebook's wireless connection is fine.

Did have a bit of a problem at the club - internet access was fine, but when I attempted to connect to a printer there I got stuff about my machine being part of a home network, and was unable to connect.

Homehub uses WPA / WPA2 , not WEP

User avatar
sabrex
Posts: 1145
Joined: Thu Jun 05, 2003 0:01
Product(s): Various
Location: England
Contact:

Re: Amilo Li1818 - no WLan driver

Postby sabrex » Mon Mar 12, 2012 12:01

hi - try switching the router to be WEP instead post back result

pjohnpope
Posts: 5
Joined: Thu Mar 01, 2012 22:33
Product(s): Amilo Li1818

Re: Amilo Li1818 - no WLan driver

Postby pjohnpope » Mon Mar 12, 2012 21:16

switched toHomehub to WEP - my computer could not see any wireless connection.

switched it back, and verified homehub working by logging on wife's computer.

Now my machine refuses to detect the wireless network at all.

Ran windows network diagnostics, which say that my wireless card is not switched on - it was. switched off and on again without fixing problem.

User avatar
sabrex
Posts: 1145
Joined: Thu Jun 05, 2003 0:01
Product(s): Various
Location: England
Contact:

Re: Amilo Li1818 - no WLan driver

Postby sabrex » Tue Mar 13, 2012 10:24

Unfortunately i think you will have to uninstall the driver from device manager and then re-install the vista one again. Looks like theres an issue with it working with your router. Start looking for the model of router - the firmware version it is running .
the channel it is set too (should be 6)


Return to “AMILO Notebook”

Who is online

Users browsing this forum: No registered users and 0 guests

cron