Stylistic Q702 Sierra MC7011 LTE Card

Moderator: ModTeam

wimpzilla
Posts: 5
Joined: Tue Nov 17, 2020 11:12
Product(s): Fujitsu Stylistic Q702

Stylistic Q702 Sierra MC7011 LTE Card

Postby wimpzilla » Thu Nov 19, 2020 0:16

Hello,

I bought 2 years ago a second hand Stylistic Q702 tablet, still working fine today.
No issues at all under Win10, but one thing i couldn't get to works is the Sierra MC7710 LTE module.

At the beginning i thought the seller had mislead me, but upon closer inspection, the module is present and connected to the motherboard.
I read that some Q702 models were available with the LTE module working and some were not.
Is there a way to know if my Q702 model is the one that come with the LTE module?

Maybe the seller added the module itself?
He thought it would be supported but this particular Q702 was not destined to have it added, so it didn't work?
Or it is because the MC7710 LTE card is maybe faulty?
Everything is up to date, bios and drivers, as far i know.

Thank you for your support.

User avatar
Ask Fujitsu
Moderator
Posts: 280
Joined: Fri Aug 02, 2019 10:02
Product(s): n/a

Re: Stylistic Q702 Sierra MC7011 LTE Card

Postby Ask Fujitsu » Wed Nov 25, 2020 14:10

Dear wimpzilla

For further investigation please provide the serial number of the affected Fujitsu device and SystemScan report:

https://support.ts.fujitsu.com/indexdow ... F4DA5645CB

Best regards
Forum Team

User avatar
Ask Fujitsu
Moderator
Posts: 280
Joined: Fri Aug 02, 2019 10:02
Product(s): n/a

Re: Stylistic Q702 Sierra MC7011 LTE Card

Postby Ask Fujitsu » Mon Nov 30, 2020 12:03

Dear wimpzilla

Please email us the original report, as it is necessary to help you with your request, to the following email so our team can take a look at the Systemscan: user.forum@ts.fujitsu.com

We look forward to hearing from you with those details.

Best regards
Forum Team

wimpzilla
Posts: 5
Joined: Tue Nov 17, 2020 11:12
Product(s): Fujitsu Stylistic Q702

Re: Stylistic Q702 Sierra MC7011 LTE Card

Postby wimpzilla » Mon Nov 30, 2020 16:13

Dear support,

Mail sent.

Thank you for your support.
Kind regards.

User avatar
Ask Fujitsu
Moderator
Posts: 280
Joined: Fri Aug 02, 2019 10:02
Product(s): n/a

Re: Stylistic Q702 Sierra MC7011 LTE Card

Postby Ask Fujitsu » Thu Dec 03, 2020 14:07

Dear Wimpzilla

Indeed, according to our database STYLISTIC Q702 with serial number ***** has been purchased with installed LTE module MC7710.

However, in the sent SystemScan report we cannot find this component - LTE/UMTS module MC7710. If customer checked that MC7710 is properly inserted and connected to the motherboard, but it does not work at all, most probably the LTE module is faulty and needs to be replaced.

Nevertheless, please check, if LTE module MC7710 is listed in Device Manager under Network Cards (Network devices) tab. Please send a screenshot of it.

Please also go into BIOS -> Advanced -> Internal Device Configurations -> WWAN (if such option is available) -> Enabled

Then please press F10 to save this change and to leave the BIOS.

Additionally, affected STYLISTIC Q702 has been delivered to the customer with pre-installed Windows 8 Pro x64. Based on sent report customer has installed his own system image which is currently Windows 10 Home x64.

Fujitsu supports Windows 10 on this hardware, but only provides the most basic drivers that require a system boot. Drivers for all other components, including the LTE module, are not available for Windows 10 installed in STYLISTIC Q702.

I´m waiting for your feedback.

Best regards
Forum Team

wimpzilla
Posts: 5
Joined: Tue Nov 17, 2020 11:12
Product(s): Fujitsu Stylistic Q702

Re: Stylistic Q702 Sierra MC7011 LTE Card

Postby wimpzilla » Fri Dec 04, 2020 16:05

Dear Support,

Thank you for the time spent to troubleshoot the issue.

I have already carefully checked the bios settings and Windows drivers.
It did not appear in the device manager but everything else works fine.
I suppose as you said, that the module is faulty, i should be able to get a laptop with LTE capability and check if the LTE appears here and determine if the card in indeed faulty.

I know the tablet is not designed for Win10, but if one have a bit of knowledge as i have, one can manage to get i work with good performances, even if being almost 7 years old.
One need to fiddle a bit with the drivers versions, which is not always an easy thing for everybody, i acknowledge that.
The tablet feel responsive and works very well for normal daily usage as internet surfing, video playback and light loads.
The only thing i would like is to have the possibility to change the fan curve settings, but no complaints aside that.

Most importantly, you answered to my main concern about the stock configuration of the tablet.
As i said, i thought the seller got the version without the LTE module and installed it afterward.
This was my main concern, if i would try to buy a LTE replacement, the replacement won't work.
I will keep you updated about.

Many many thanks, great support from Fujitsu.
Kind Reagrds, Wimpzilla.

User avatar
Ask Fujitsu
Moderator
Posts: 280
Joined: Fri Aug 02, 2019 10:02
Product(s): n/a

Re: Stylistic Q702 Sierra MC7011 LTE Card

Postby Ask Fujitsu » Mon Dec 07, 2020 10:52

Thank you for the kind words wimpzilla, and for trusting us.

If you need any further assistance, always feel free to reach out again!

Best regards
Forum Team

wimpzilla
Posts: 5
Joined: Tue Nov 17, 2020 11:12
Product(s): Fujitsu Stylistic Q702

Re: Stylistic Q702 Sierra MC7011 LTE Card

Postby wimpzilla » Sun May 16, 2021 17:24

Hello dear Support.


I spent some time troubleshooting the MC7011 module:
-I plugged the LTE card into my Lenovo laptop, the card halts the boot because white listed.
-I plugged the card into a Win7 laptop, the card appeared into the device manager, without drivers.
So i assume that the LTE card is detected and working, still it is not detected on the Q702.

I went a step further and installed Linux Debian on the tablet.
Unfortunately even Linux cannot detect the MC7010 LTE module.
Almost everything is recognized and works flawlessly, touchscreen and stylus included.

At this point, the last culprit would be the pci-e adapter card, where the LTE card is attached to.
Looking for this part n°CP588782-XX/CP588781-Z1, i noticed there are multiples version of this adapter.
The one i got doesn't have the SMD package soldered to it.

Please let me know, if the pci-e adapter card i got, is the right one for the LTE card.
I even tried to tape the card connector pins, due to a possible detection conflict between the pci-e and the usb.
But nothing i tried until now, managed to woke up the card on the Q702.

Kind Regards, Wimpzilla.
Attachments
IMG_2.jpg
IMG_2.jpg (1.86 MiB) Viewed 2251 times
IMG_1.jpg
IMG_1.jpg (1.97 MiB) Viewed 2251 times

User avatar
Ask Fujitsu
Moderator
Posts: 280
Joined: Fri Aug 02, 2019 10:02
Product(s): n/a

Re: Stylistic Q702 Sierra MC7011 LTE Card

Postby Ask Fujitsu » Wed May 19, 2021 10:09

Dear Wimpzilla

the feedback we received was that the Stylistic Q702 reached the End of Life / End of Support and therefore maintenance support, as well as spares logistics, had been discontinued.

We do not produce and distribute spare parts for Stylistic Q702 anymore.
Best regards
Forum Team

wimpzilla
Posts: 5
Joined: Tue Nov 17, 2020 11:12
Product(s): Fujitsu Stylistic Q702

Re: Stylistic Q702 Sierra MC7011 LTE Card

Postby wimpzilla » Sun May 23, 2021 13:58

Hello Dear Support,

I was not asking about getting a replacement part from Fujitsu.
I'm fully aware that you do not support this device anymore, it's 7 years old.

I was wondering, if the pci-e adapter was the right one to accommodate the LTE module.
Because i found different versions of this same pci-e adapter card.


Kind Regards,
Wimpzilla.

User avatar
Ask Fujitsu
Moderator
Posts: 280
Joined: Fri Aug 02, 2019 10:02
Product(s): n/a

Re: Stylistic Q702 Sierra MC7011 LTE Card

Postby Ask Fujitsu » Fri Jun 18, 2021 11:07

Dear wimpzilla

The feedback we got was that based on the sent photos, we assume that the purchased PCIe adapter is the right one for MC7011 LTE module. However, the purchased adapter can be faulty or a controller on the mainboard responsible for recognition of LTE module, can be defective and that's why the LTE module is not detected. At this point, it is difficult to find the clear reason.

Best regards
Forum Team


Return to “STYLISTIC Tablet PC”

Who is online

Users browsing this forum: No registered users and 1 guest

cron