Battery charging update tool issue

Moderator: ModTeam

Posts: 1
Joined: Mon Dec 03, 2018 21:02
Product(s): lifebook ah531

Battery charging update tool issue

Postby tuney » Wed Dec 05, 2018 20:41

I have a Lifebook AH531 originally running Windows 7 (now Win 10) with an i3 processor. When I try to run the battery update BIOS 1.30 tool, every time I get the light blue screen sad face error message and my machine restarts. Can any body help me out with a solution to this rather annoying problem?

Posts: 7
Joined: Wed Nov 14, 2018 10:49
Product(s): lifebook

Re: Battery charging update tool issue

Postby einmc » Sat Dec 08, 2018 7:35

Windows 10 to that machine will run much slower and you need a more memory on it, that specs will be more suitable if you stay on windows 7. I made that kind of upgrade and went back to much lower OS version because it significantly slow my machine when I use windows 10.

Posts: 973
Joined: Thu Jun 22, 2006 15:32
Product(s): Scaleo Pi2662, Primergy

Re: Battery charging update tool issue

Postby me@work » Sun Dec 09, 2018 9:48

Sorry, but imho, einmc's post is of absolutely zero significance to the original poster's issue...
Plus, it's going to be hazardous after Jan 2020, if the notebook remains connected to the inernet.

Anyway, back to OP:
What is a "battery update BIOS tool"?
Current BIOS version for AH531 (YLDNxxxxxx) is indeed 1.30, while latest version for AH531 (YLDPxxxxxx) is 1.24. Do take care to use the appropriate update bundle for your machine.

Then, there's no such thing as "the" light blue screen sad face error message. The sad face is common (also on the opposite side of the screen), but there is a vast amount of possible different causes, which get indicated by the hexadecimal message number (and accompanying text) on that screen. You might either want to disable "automatic restart on system error" in your Windows and reproduce the error to determine this text, or search the system event log of your Windows installation for an entry decribing this "unexpected system restart".
With this information, search for possible solutions to that specific cause.

Finally, you might want to try to update BIOS using the Admin Update pack for a bootable USB stick instead of the Windows Update utility, which is certified only to run on Windows up to version 8.

Posts: 1
Joined: Tue Dec 11, 2018 18:01
Product(s): AH530

Re: Battery charging update tool issue

Postby STEVOAH531 » Wed Dec 12, 2018 14:01

I get the same on my AH531
Light blue screen since update done 7th December 2018
it fails to install correctly
i will attach some images showing the process so far
Now time to study error as shown
anyone else have idea's
IMG_0810 (Medium).JPG
IMG_0810 (Medium).JPG (55.88 KiB) Viewed 12768 times
IMG_0808 (Medium).JPG
IMG_0808 (Medium).JPG (90.29 KiB) Viewed 12768 times
IMG_0807 (Medium).JPG
IMG_0807 (Medium).JPG (139.12 KiB) Viewed 12768 times

Posts: 973
Joined: Thu Jun 22, 2006 15:32
Product(s): Scaleo Pi2662, Primergy

Re: Battery charging update tool issue

Postby me@work » Wed Dec 12, 2018 16:52

I'm sorry, but I won't be of any further help with this issue, unfortunately...

You already determined the causing software (WinFlash64.exe), and this creates a PAGE_FAULT_IN_NONPAGED_AREA. It seems that only Fujitsu would be able to rectify this problem, and given the fact (or impression) that really NO (i.e. ZERO) official Fujitsu person responds to posts in this forum, you might be well advised to check the problem with your local authorized Fujitsu support partner...

What astonishes me a little about the screenshots, is that this battery tool tries to download a BIOS updater. Did you check the BIOS version of your notebook? Is it latest, or in case it is not, did you already try to update BIOS separately first, and start the battery control tool after this procedure again?
I can't promise this will help, but perhaps it might serve as a circumvention...
Good luck!

Posts: 1
Joined: Thu Jan 03, 2019 19:33
Product(s): Lifebook AH531

Re: Battery charging update tool issue

Postby AngryDad » Mon Jan 07, 2019 14:18

I had the same problem. Tried a whole host of different things to resolve the issue but nothing worked. Then I came across a post that described locating the folder that hosted the update files and delete the folder. I found the folder. It was in Local Disk (C), Program Files, Fujitsu, FUJ02E3_BatteryChargingControlUpdate

The post I saw stated you had to access the folder as an admin and change the settings to allow you to delete the folder. Anyhow I couldn't delete the folder however instead I accessed the FUJ02E3 folder and just deleted the files in the folder (I think there were 2 files in there but just delete everything) I restarted my laptop and the update had been removed.

Hope this helps.

Return to “LIFEBOOK”

Who is online

Users browsing this forum: No registered users and 1 guest