Reversing Legacy Bios Setting to UEFI Mode

Moderator: ModTeam

Posts: 8
Joined: Tue Dec 31, 2013 14:54
Product(s): Lifebook AH512

Reversing Legacy Bios Setting to UEFI Mode

Postby fujiman123 » Mon Aug 24, 2015 12:33

I have been using legacy mode bios for some years now on my Lifebook AH512 LT, since it allows me to run Linux software. However, a few years back, when I was running Windows 8.1, I tried to return the bios settings back to UEFI mode, but found that some parts of the menu that I needed to access were greyed out. As I tried to get round the problem I suddenly found the bios telling me that the main HDD was now locked for security reasons, and no matter what I did, I could not rectify the matter, even though I knew my bios password. My computer seemed 'bricked', not a nice feeling!

In desperation, I rang Fujitsu Service Centre, who were very helpful. They guided me through what appeared to me a few trapdoor (not obvious) access points on the bios menu and within a few minutes my bios was reset to UEFI. Unfortunately, it was all done so quickly and I was so relieved, that I did not have the foresight of mind to write down the procedure followed.

My OS is now Windows 8 and I want to upgrade to Windows 10 to try it out. However, I need to upgrade to Windows 8.1 to do this. I again want to reset my bios to UEFI mode, but I am petrified of locking the HDD again.

I have tried accessing the UEFI settings via Windows 8 Advanced Settings mode and using F9 to set everything to default mode, but this does not work.

From the forum the exact instructions to disable UEFI to legacy mode are:
use the following settings
- Security - Set supervisory password
- Security – Secure Boot Configuration – Secure Boot Option : [Disabled]
- Advanced – Boot Configurations – Fast Boot : [Disabled]
- Advanced – Boot Configurations – CSM : [Enabled]

Is restoring UEFI mode, merely a process of reversing the above steps, as I thought this what I did before!

Any help or advice on the above would be much appreciated.

Thanking you in anticipation.

Posts: 2
Joined: Sat Feb 10, 2018 2:30
Product(s): Fujitsu lifebook AH512 laptop

Re: Reversing Legacy Bios Setting to UEFI Mode

Postby anmool » Sun Mar 04, 2018 18:31

hi I have same laptop how to unlock UEFI mode on lifebook ah512 please tell me procedure
I m waiting for your procedure

Posts: 1
Joined: Tue Dec 18, 2018 11:49
Product(s): ah512

Re: Reversing Legacy Bios Setting to UEFI Mode

Postby russ3001 » Tue Dec 18, 2018 12:11

Any update on this one, I'm having the same problem?

Posts: 6
Joined: Sat Nov 24, 2018 17:08
Product(s): Lifebook, fujitsu laptop

Re: Reversing Legacy Bios Setting to UEFI Mode

Postby sugetsu » Sat Dec 22, 2018 12:13

Updates? I'm facing this issue now.

Posts: 7
Joined: Wed Nov 14, 2018 10:49
Product(s): lifebook

Re: Reversing Legacy Bios Setting to UEFI Mode

Postby einmc » Fri Dec 28, 2018 16:06


Posts: 5
Joined: Sun May 27, 2007 10:48
Product(s): RX500 S7, RX300 S5

Re: Reversing Legacy Bios Setting to UEFI Mode

Postby kzimmer » Mon Mar 04, 2019 11:31

I just had the same problem on a Fujitsu P400 desktop PC. I was able to do UEFI install again (reverting from BIOS) by restoring the BIOS settings on the 'Save & Exit'-Page and selecting 'Restore Defaults' and 'Restore User Defaults'.

Return to “LIFEBOOK”

Who is online

Users browsing this forum: No registered users and 1 guest