Lifebook E780 Firmware + ME update fail (unknown error).

Moderator: ModTeam

Posts: 3
Joined: Wed Sep 13, 2017 0:07
Product(s): Lifebook E780

Lifebook E780 Firmware + ME update fail (unknown error).

Postby andreatheflyer » Wed Sep 13, 2017 7:24

I download the update package to fix the Intel Firmware vulnerability issue (BIOS v.1.21 + ME update) but when I run it, i get "Unknown Error" and the program exits.
I tried on both Windows 10 and Windows XP (dual boot), which have both installed the Intel AMT package as well as the DeskView Client. Since I put on a SSD, I even tried to run the update on the original Hard Drive, but in any case I get the same unknown error.
Any help please?
(Tip: the notebook underwent a motherbord replacement and since then the machine serial number is no longer present. May it be the cause?)

Posts: 2
Joined: Sun Sep 17, 2017 13:59
Product(s): Lifebook E781

Re: Lifebook E780 Firmware + ME update fail (unknown error).

Postby phantomias » Mon Sep 18, 2017 8:55

I have the same problem with my E781.

Posts: 3
Joined: Wed Aug 30, 2017 11:23
Product(s): Lifebook S904

Re: Lifebook E780 Firmware + ME update fail (unknown error).

Postby MS9EydNzp » Fri Sep 22, 2017 7:54


ich habe das gleiche Problem mit einem Windows 8, das von USB-Stick startet - s. hier: viewtopic.php?f=65&t=47992

Mit freundlichen Grüßen
Chris Vogel

Posts: 5
Joined: Tue Apr 26, 2016 12:28
Product(s): Esprimo V5505

Re: Lifebook E780 Firmware + ME update fail (unknown error).

Postby Gerald » Thu Aug 15, 2019 23:14

Ok, this is a bit old, but if someone comes across the "Exit with unknown error." Message from the the System Firmware Update utility, I think I have a solution. I tried just about EVERYTHING to get this to work, including
- installing all kinds of Intel ME drivers and fujitsu drivers in Windows 10
- a fresh windows 7 installation with drivers and updates
- updating from 1.15 to 1.20 with the provided ISO first

Nothing worked. Before giving up, I wanted to see if there was some more specific error message, so I looked into where the installer unpacks its files before starting the update:
(Hint: AppData => Local => Temp - found this by using task manager to check which process is associated to the application displaying the error and then opening the path where the process exe came from - all little tricks in Task Manager).

So now I finally had the directory. Which contained a couple of things you can execute:
- I did not do a final analysis, but probably the Fujitsu "update.exe" which displays the error runs into some problem checking the old ME version and then bails (Hey Fujitsu, how about some Quality Control Department?).

But you can update everything manually and it works perfectly fine!
1) run cmd.exe as Administrator and navigate to the path with the extracted files (I copied the entire directory to the desktop first, fearing that the Fujitsu tool might remove it from the temp path upon closing it - did not check if it actually does that)
2) run update-me.cmd
3) after the reboot, run cmd.exe as Administrator again, navigate to the path and now run biosupd.exe
4) click about 7-8 silly checkboxes confirming you are not a moron (who pulls the power plug or runs games during the BIOS flash) and run the bios update.

Running update-me.cmd from the GUI did NOT work for me. For biosupd.exe you probably don't need cmd, but this is what I did. Also, you probably can first update BIOS, then ME, but this is not what I did and for me "ME first" worked so this is what I suggest you do.

Hint: if you run (as admin) update-me.cmd again afterwards it will now complain that it needs a specific switch to update to the same version. If it does that, you know know you actually have the version that came in the package. Regarding BIOS version, just check the BIOS (F2). I'm at BIOS v1.21 on the E780 now, finally after hours.

Shame on you Fujitsu! :roll:

Return to “LIFEBOOK”

Who is online

Users browsing this forum: No registered users and 1 guest