Slave IDE Disk Not Recognised in BIOS on Scenic X102

Moderator: ModTeam

flintstone

Slave IDE Disk Not Recognised in BIOS on Scenic X102

Postby flintstone » Mon Jun 05, 2006 14:08

I am trying to add a slave IDE disk (a Seagate ST380011A 80Gb - identical to the supplied ST340014A system disk except double the capacity) to the primary channel of a SCENIC X102.

The slave disk is not recognised or detected by the BIOS.

1) I have tried cable select and master/slave configurations.
2) I have swapped the IDE cable.
3) The new disk is recognised perfectly if it is configured as a master on the IDE channel (with the existing system disk temporarily disconnected).
4) Standalone Seagate diagnostics confirm disk and controller OK, when (a) existing system disk is connected by itself, (b) new slave disk is connected by itself.
5) Windows XP recognises both the system master and slave disk which work prefectly OK, except that Add New Hardware must be executed to pick up the slave after each reboot because the BIOS will not recognise the second slave device.
6) Until the Add New Hardware dialogue is executed, the drive activity LED stays permanently illuminated. After the drive is added to Windows, the LED behaves normally.

I am sure this is a BIOS issue. Clearly the drives and the controller are working because Windows can use them perfectly OK.

Anyone else suffered anything similar?

Bonzo_5

Slave IDE Disk Not Recognised in BIOS on Scenic X102

Postby Bonzo_5 » Tue Jul 18, 2006 11:15

Hi, Did you manage to sort out your HDD/BIOS issue? because I have exactly the same problem, but no help or suggestions forthcoming.
regards

flintstone

Reply to Bonzo_5

Postby flintstone » Tue Jul 18, 2006 20:37

No I didn't solve the problem. I just keep adding the slave using Add New Hardware at each boot up.

Are your symptoms identical? What make/model disk are you adding? Is you machine a Scenic/X102 with Celeron? Have you tried all the perrmutations and combinations of master/slave and cable select? Does your HD LED stay permanently illuminated until you add the new disk to XP?

There is definitely nothing wrong with my disk. I swapped it from my old Dell into the X102. It was working perfectly in the Dell as a slave and the Seagate diagnostics run completely cleanly. Once the disk is added to XP, it is perfectly usable in the machine. The only issue is the BIOS recognising it at start up.

If your problem is identical, I think I'll pursue the issue further with Fujitsu-Siemens.

Bonzo_5

Slave IDE Disk Not Recognised in BIOS on Scenic X102

Postby Bonzo_5 » Tue Jul 18, 2006 21:08

Hello again, we have an identical problem and have both tried the same,what you originally wrote could have been written by myself right down to the light staying on until the slave is added with add/remove hardware.The only difference is my master HDD is a Samsung 40Gb,My BIOS was updated in Sept 05.Have you updated your BIOS.I have also tried my slave HDD in another type of scenic machine (not an X102 and all works fine.

flintstone

Postby flintstone » Tue Jul 18, 2006 22:58

I checked out the BIOS version in June when I had the problem and confirmed I was on the latest. My machine was manufactured in Nov 2005 although I only bought it in March this year. This is the version

BIOS Version/Date FUJITSU SIEMENS // Phoenix Technologies Ltd. 5.00 R1.11.2140.02, 19/09/2005

Is this the same as yours?

I'd given up on this one, but now it sounds to me like there may be a systematic problem with the hardware or the BIOS.

I doubt whether many people upgrade these Celeron X102 machines with second disks because they are really office machines designed for use on a network - although I must say the machine is excellent and very good value for money and does a great job as a general purpose web browser/e-mail/simple tasks machine.

My machine is under FS warranty so I think I'll have another go at contacting FS.

Meanwhile, I don't think there is much we can do - I certainly spent a couple of weeks trying every permutation and combination of jumpers/cables etc etc before I gave up.

dclowes

Postby dclowes » Wed Jul 19, 2006 9:10

got to be a bios issue... are you sure you are running the latest bios? check the update page. I bugs me that fujitsi use oem bios's, and you cannt update from the manufacturers site.......

A ide raid card would fix your problem (under £20), but it seems a silly thing to do when your motherboard/bios should support it.


Return to “SCENIC”

Who is online

Users browsing this forum: No registered users and 2 guests