[Amilo Li 1718] Touchpad button failure?

Moderator: ModTeam

Posts: 1
Joined: Mon Mar 24, 2008 16:14
Product(s): Amilo Li 1718

[Amilo Li 1718] Touchpad button failure?

Postby Spookey » Mon Mar 24, 2008 16:20

Just purchased a shiney new Amilo Li 1718 and for the first day the right hand button (touchpad) worked fine but 2 days later and it doesn't seem to respond at all. Left button and touchpad itself work just fine - HELP! It's only 3 days old and going wrong already?? :cry:

Tried rebooting - no change.
Swapped buttons via control panel and 'actual' left button works but 'actual physical' right button still gives no response.

I'm getting really bothered as I had to buy on a budget and now it's all going wrong :( - I use the right mouse click an awful lot and am lost without it - please can anyone suggest anything?

S. x

Posts: 73
Joined: Thu Jan 17, 2008 21:59
Product(s): Fujitsu Siemens Amilo Li 1718.
Location: United Kingdom

Re: Touchpad button failure?

Postby matt-hall-08 » Mon Mar 24, 2008 18:38

One Tip:

Use an external mouse?
Amilo Li 1718, Core Duo, Vista Home Premium, 896MB RAM +128MB used for Graphics!!, 98.1GB HDD, 12GB used for System Recovery! For £349.99!

Return to “AMILO Notebook”

Who is online

Users browsing this forum: No registered users and 1 guest