Amilo Pa1510 and OpenGL -> crash

Moderator: ModTeam

bkotsias
Posts: 5
Joined: Sun Nov 26, 2006 12:38

Amilo Pa1510 and OpenGL -> crash

Postby bkotsias » Sat Oct 13, 2007 18:20

Hello. My laptop is an Amilo Pa1510, Turion64, 1GB RAM, Radeon Xpress 1100 128MB.

I have just downloaded the latest ATI Catalyst drivers (v7.9) and have discovered there is a serious bug with the OpenGL driver.

The bug occurs when I use Anim8or (freeware 3d modeling and animation - http://www.anim8or.com/main/index.html).

It uses OpenGL to display the 3d mesh. Every time its window is updated, the memory usage (shown in Task Manager) increases constantly and it never drops. For example, if I move another window in front of the Anim8or's window, there will be a dramatic memory accumulation. After a few minutes, it reaches ~2GBs and it crashes.

I have contacted the Anim8or author and he is sure there is no bug with his code, but it's rather an OpenGL bug. The problem is "solved" if I install some 3rd party "ATI Omega drivers" and DISABLE OpenGL hardware acceleration. But those drivers have other issues so I'd rather use the official ones.

I have also contacted ATI/AMD about it but they say it's not their problem(!) and that the laptop manufacturer should provide the correct drivers to solve the problem!

I am really sad about this situation and I have almost regretted buying an ATI/AMD equipped laptop. I would really like to hear others' thoughts and suggestions.

Thank you for your time. Kind regards,

Bill Kotsias

Return to “AMILO Notebook”

Who is online

Users browsing this forum: No registered users and 2 guests

cron