ATI latest drivers - in this topic

Moderator: ModTeam

User avatar
Mariner
Posts: 86
Joined: Sat Oct 28, 2006 11:27

Postby Mariner » Tue Aug 28, 2007 11:35

If you are sick and tired of the ModTool for Windows Vista and you absolutely require the original Ati Mobility driver, you can download some versions from here:
http://www.nodevice.com/driver/company/ATI/page3.html
Amilo D1845 - Hitachi Travelstar 160GB 5400rpm, 2x Kingston KVR400X64SC3A/1G. (Yes it supports 2GB of DDR400!)
Asus F3Ja - Hitachi Travelstar 250GB 5400rpm, 2x Kingston KVR667D2S5/1G.

shtraue
Posts: 250
Joined: Mon Jul 17, 2006 9:20

Postby shtraue » Tue Sep 11, 2007 8:46

* Catalyst Mobility 7.9 for Windows XP
* DH Mobility Modder.NET has been updated on 26th August to version 0.8.7.0

Previously I've mentioned hotfix 940105 for Vista, and me being unable to install it, now, I was able to install it after all - by switching off the internet connection.

silviuf42
Posts: 1
Joined: Tue Sep 11, 2007 16:09

Windows Vista outdated drivers

Postby silviuf42 » Wed Sep 19, 2007 16:15

Although I have read the other posts and didn't find anything, I ask if anybody knows about some new ATI Vista drivers (FS, mobility radeon x1400)? It's "great", now I am using a 1-year old driver and it seems that fujitsu siemens doesn't even give a s**t on our problems. Why on earth on my laptop says "Windows Vista Capable", and after Vista install, I can't get any decent graphic drivers? On Dell site, those guys have released for x1400 a driver from 05.2007, why can't FS do the same, they are more special or what? Or better, they should have let ATI do this work, they wanted to do this but FS said NO. It's a shame. Well, it's for sure this was the first and the last time when I bought a FS computer. should have bought a dell or toshiba. oh yeah, now they will tell us that they don't work so much on gaming issues, that they create only business notebooks (working in word or excel could be done even with a 500USD notebook, for my notebook I have other expectations). "great" company, nothing else to say.

Anyway, does anybody have a clue how can I update my ATI drivers? I have already tried the driverheaven mobility modding tool, but it didn't work, although the instalation was successful, the screen turned darker than usual (it had nothing to do with brightness or contrast), so I had to uninstall. I am using an Amilo pi 1536, ATI X1400 128 VRAM. Thanks.

User avatar
ahuramazda
Posts: 34
Joined: Mon Sep 11, 2006 10:45
Product(s): Amilo M1425
Location: Turkey

STALKER PERFORMANCE:)

Postby ahuramazda » Sat Nov 03, 2007 7:04

After usuing 2x512MB Kingston DDR333 (2.5-3-3-7) SO-DIMM (the old couple was Hynix 2x256MB 2.5-3-3-7),I can play Stalker shadow of chernobyl as good as a desktop computer. The average frame rate is 35 frames per second! My graphics card is Ati Mobility Radeon 9700 (128MB-128bit-398/460) and I use Catalyst 7.10. I advise you to install this newest driver, it increases performance dramatically :)

Chris1234
Posts: 7
Joined: Mon Nov 12, 2007 0:39

Postby Chris1234 » Thu Dec 06, 2007 21:32

hey, thanks for your support. i've got a problem regarding my display drivers. in many games the resolution is set to 800x600 and nearly all newer games (i.e. cod4) don't work anymore.

although it seems i've got the latest drivers (7.11), it seems i've got a real problem.

here is my catalyst control center->graphics software window:

Code: Select all

Driver Packaging Version   8.432-071101a-054435C-ATI   
Catalyst® Version   07.11   
Provider   ATI Technologies Inc.   
2D Driver Version   6.14.10.6734   
2D Driver File Path   System/CurrentControlSet/Control/Video/{100D81C6-6504-427B-B7D1-1CAD01B20ED6}/0000   
Direct3D Version   6.14.10.0540   
OpenGL Version   6.14.10.7056   
Catalyst® Control Center Version   2007.1101.2317.39832   


thank you for your help in advance.

User avatar
ahuramazda
Posts: 34
Joined: Mon Sep 11, 2006 10:45
Product(s): Amilo M1425
Location: Turkey

Postby ahuramazda » Sat Dec 08, 2007 9:38

What is the type of your GPU? If it's a kind of oldest chipset, it cannot work as efficiently as a newest chipset, so the resolution is set to 800x600 and the lowset settings are chosen automatically. My GPU is Ati Radeon Mobility 9700 128MB and I can play Call of Duty 4 with a frame rate of 35fps/second! even by using the highest settings and 1280x800 resolution, but I choose the performanse settings from Catalyst Control Center- 3D Settings tab :)

Chris1234
Posts: 7
Joined: Mon Nov 12, 2007 0:39

Postby Chris1234 » Sun Dec 09, 2007 0:45

uh, sry, it is a radeon x1800. the problem is that many games work, but the heat rockets sky high. i've monitored the core temperatures under the use of complex games like cod4: most of the time it swaps between 65 and 74, which is much too high (i've got a xi1546). is there a cheap way to cool it correctly by installing tools or driver and/or buying new (external) hardware?

User avatar
ahuramazda
Posts: 34
Joined: Mon Sep 11, 2006 10:45
Product(s): Amilo M1425
Location: Turkey

Postby ahuramazda » Mon Dec 10, 2007 11:19

Since I have an exam of Structural analysis 1 hour later, I'll try to make an advice to you after that :D

User avatar
sstone
Posts: 39
Joined: Fri Dec 14, 2007 12:52
Product(s): Esprimo Mobile V5545(T7300, 2GB, 250GB, HD2400, XP SP3)
Location: NYC

Postby sstone » Mon Dec 17, 2007 13:20

Just in case if anyone have a similar problem...

I have the Esprimo Mobile V5545 with Ati Radeon Mobility HD 2400 with Windows XP.

I downloaded the Ati HD 2400 driver form the FSC page(drivers for V5545) and some programs(like Photoshop Lightroom, WLM Plus) had extremely poor performance, so I tried to download the driver from Ati's homepage, this driver was unable to install(error said that I don't have compatible hardware or OS(wich both I had)).

Anyway the solution is:
- Download the latest Catalyst Mobility, MS XML4 and the Ati ModTool(if on XP you will need .net framework too, just try to run the mod first, if you get the .net error, download it),
- follow the instructions on the ModTool page.

Now I don't have graphics problems anymore, all apps are working just fine so far.

Sorry if someone wrote the solution down already, i was unable to find it.

Chris1234
Posts: 7
Joined: Mon Nov 12, 2007 0:39

Postby Chris1234 » Wed Dec 19, 2007 17:13

it doesn't work on my rig. newer drivers cut the overall performance of my system in half. also the windows needs eons to load and shut down itself.

thanks anyway. so i have to make consequences and will never buy a system from fsc again.

Bright
Posts: 1
Joined: Wed Sep 06, 2006 8:48

Postby Bright » Tue Dec 25, 2007 18:45

I also have a xi1546 and seem to have fixed the problem described by Chris by using an external cooler. No more intermittent frame rate slowdowns! :)

The cooler is made by Akasa.

I wanted to ask:

I am using version 7.5 of the Catalyst driver, should I update to the latest version?

My games seem to be running fine at the moment, although Gears Of War does warn me that I don't have a high enough driver version.

Will updating improve or decrease my performance..?

Thanks.

Andrew.

Chris1234
Posts: 7
Joined: Mon Nov 12, 2007 0:39

Postby Chris1234 » Fri Jan 18, 2008 0:02

well, it works now, thank you for your help @all.
i can somehow install the new drivers just by executing the official driver exe. though, it took my some time and i never understood, why it works now and not when i tried to install the drivers via mobilitydotnet or stuff.

thanks.

myron81
Posts: 9
Joined: Sat Feb 03, 2007 3:15
Product(s): Pi 3560, Intel P9500 2,53MHz, Nvidia 240M GT, 6GB RAM
Xi 1546, Intel T2400 1,83MHz, Nvidia 8600M GT, 2GB RAM

Postby myron81 » Thu Feb 14, 2008 16:39

Just a hint for Amilo Xi 1546 owners (at least).

Installing the latest Catalyst 8.2 drivers using Mobility Moder 0.8.8.0 under XP proffesional results a permanent system halt.

Try avoiding this version.

In case you already tried it and having problems uninstalling dont panic to format everything, try:

1) Booting through safe mode (F8 When Windows start up).

2) Uninstalling the ATI drivers from add/remove programs and restart.

* In case you have an Could not load file or assembly 'CLI.Implementation or MOM could not be loaded
error.

try:
3) After following the above steps (1), (2), delete the ATI Technologies\\ATI.ACE folder from your Program Files directory. (It should have an ATI.ace folder which should be deleted).

4) Run msconfig and manually untick from startup tab CLIStart and click apply.

The above should do the trick, then you are free to boot windows normaly and install any Catalyst version you had before that.

Chris1234
Posts: 7
Joined: Mon Nov 12, 2007 0:39

Postby Chris1234 » Mon Feb 18, 2008 22:21

i already figured that out. what really bothers me is my graphics card. regardless of what driver version i use, i am constantly experienceing graphic bugs (like vertical and horizontal lines across the screen and artifacts). seems like a defect gpu, but the errors are different in other games. for example in team fortress2 there are no lines or artefacts, i always get the message of a low ram page file size and gears of war and unreal tournament 3 crash randomly.

i know the amilo xi 1546 doesn't really meet the reqs of the last games, but games like guild wars (where the artifacts and such appear) should work properly and they worked flawlessly a long time ago.

i guess the notebook was a malinvestment.

myron81
Posts: 9
Joined: Sat Feb 03, 2007 3:15
Product(s): Pi 3560, Intel P9500 2,53MHz, Nvidia 240M GT, 6GB RAM
Xi 1546, Intel T2400 1,83MHz, Nvidia 8600M GT, 2GB RAM

Postby myron81 » Mon Feb 18, 2008 22:42

You are not the only one experiencing these issues.

Nobody can find a proper explenation on why this happens. My guess is that the lifespan of this laptop is about a year as it used to run all games without glitching( same drivers, games, OS, Bios version etc) but after a year most of its owners are experiencing these issues.

http://www.laptopvideo2go.com/forum/index.php?s=77a232adac9d289004ed5800b93f182f&showtopic=14975



GoW runs crappy on my laptop as well. The only game which rans smoothly and is stable most of the time is Call of Duty 4.


Return to “AMILO Notebook”

Who is online

Users browsing this forum: No registered users and 3 guests