M3438g - Cooling fan is always running under linux

Moderator: ModTeam

Lavrinenko
Posts: 15
Joined: Mon Nov 07, 2005 1:01
Location: Moscow, Russia
Contact:

M3438g - Cooling fan is always running under linux

Postby Lavrinenko » Thu Jan 12, 2006 9:34

Hello,
recently I purchased amilo m3438g and installed OpenSuSE 10 on it as second OS. Everything works just great except that cooling fan is always running, despite of load. Enhanced speedstep works perfectly in Linux and processor is almost always running at 800MHz (office load - wordprocessing/internet surf). I've opened TT with linux kernel ACPI developers, please read here: http://bugzilla.kernel.org/show_bug.cgi?id=5670

Please advise.

JTRIP

Postby JTRIP » Sat Jan 14, 2006 16:27

It happens the same to me with a 7440 under all distributions i tried. Till i tried Suse 10, in the first boot the fan magically dropped its revolutions slowly till it stopped. I tought: great! Then i went to sleep and the next day when i booted on Suse it was again at full revolutions and no matter what i tried it wouldnt ok. i have all powersave modules loaded and the FN1 reports fan should be off, but it obviously isnt.
Since then ive tried reinstalling Suse from scratch several times but it wont work again, a complete mistery to me. Im kind of novice when it comes to linux but that the same machine comes out of an identicall installation procedure in a different state seems quite strange to me.

Cya

ParanoidAndroid

Postby ParanoidAndroid » Sat Jan 14, 2006 16:58

Well maybe this will help.
On my Amilo L7300 the fans (I have two fans) are both on at boot but the kernel reports them as being off.
My manual fix is to first report them as off to the kernel and the fans are then really turned off:
# echo 3 >> /proc/acpi/fan/FN1/state
# echo 3 >> /proc/acpi/fan/FN2/state

After that I turn them on
# echo "on" >> /proc/acpi/fan/FN1/state
# echo "on" >> /proc/acpi/fan/FN2/state

Then the fans automatically run when the temperature is above 50C and turn off when it's below 40C again.

Hope this helps you!

Lavrinenko
Posts: 15
Joined: Mon Nov 07, 2005 1:01
Location: Moscow, Russia
Contact:

Postby Lavrinenko » Thu Jan 19, 2006 9:29

Thanks for your replies. The main problem is that there's no /proc/acpi/fan/FN?/ subdirectories, /proc/acpi/fan/ directory is empty on M3438G under SuSE. I tried various kernels from HEAD, but no luck.

torkos

Postby torkos » Sat Mar 25, 2006 11:14

try to load the fan module

modprobe fan

akasa

Postby akasa » Tue Apr 04, 2006 19:22

I've the same problem with SUSE 10 on Amilo M1439G. There is a solution?
Kernel module seems to be load:
[...]
cpufreq_ondemand 6044 1
cpufreq_userspace 4444 0
cpufreq_powersave 1792 0
speedstep_centrino 7508 1
freq_table 4612 1 speedstep_centrino
[...]
fan 4996 1
thermal 14472 0
processor 24512 2 speedstep_centrino,thermal
[...]

but
linux:/proc/acpi/thermal_zone/THRM # cat cooling_mode
<setting not supported>
linux:/proc/acpi/fan
empty

Thanks to all!!!


Return to “AMILO Notebook”

Who is online

Users browsing this forum: Google [Bot] and 1 guest