THTTPD mit PHP Function mail()

TIPPS UND TRICKS, FAQ

Moderator: ModTeam

Lasertechniker
Posts: 3
Joined: Thu Jun 19, 2008 9:29
Product(s): AMS150
Contact:

THTTPD mit PHP Function mail()

Postby Lasertechniker » Mon Jun 23, 2008 11:42

Hallo,
versuche momentan ein Forum auf dem AMS zum Laufen zu bringen,
wenn ich jedoch einen Benutzer anlegen will und das System eine eMail
verschicken will kommt folgende Fehlermeldung :
Fatal error: Call to undefined function: mail() in /mnt/.zap/web/forum1/functions.php
Kann es sein das die "function mail()" im PHP fehlt ?
Wenn ja, könntet ihr eine mit Kompilieren ?
Grüße
Udo

Habe es übrigens auch mit lighttpd ausprobiert, habe da den HTTP Fehler 500
und schon wenn ich die index.php starten will, im Log steht :
2008-06-23 11:22:21: (server.c.1475) server stopped by UID = 0 PID = 1
2008-06-23 11:23:03: (log.c.75) server started
2008-06-23 11:23:21: (mod_fastcgi.c.2471) unexpected end-of-file (perhaps the fastcgi process died): pid: 900 socket: unix:/tmp/php-fastcgi.socket-1
2008-06-23 11:23:21: (mod_fastcgi.c.3281) response not received, request sent: 978 on socket: unix:/tmp/php-fastcgi.socket-1 for /forum1/index.php , closing connection


Wäre dankbar für Hilfe !!!

User avatar
lochness
Posts: 3224
Joined: Sat Feb 04, 2006 20:42
Product(s): Myrica TV P42-2H
AMC 570 SAT (3.2.419 + VZD2)
AMC 370 SAT (1.6.115+VZD2)
AMP 150 (1.03.28eu)
3 x AMS 150 (V2.00 + NExt V2.0.06)
SBLAN2 R1.0 (V2.00 + NExt V2.0.06)
SBLAN2 R1.1 (V2.00 + NExt V2.0.06)
Storagebird DUO 35-LR (V1.03)
SB-L V1 (80GB, NetHDD007-0802)
Celvin Q800 4x2TB
Celvin Q700 2x1TB
Celvin Q600 1x2TB
Location: Bad Lippspringe

Re: THTTPD mit PHP Function mail()

Postby lochness » Mon Jun 23, 2008 20:43

Lasertechniker, wir müssen da beide Webserver auseinanderhalten.
thttpd + php 4.4.6 + optional mysql ist nicht selbst kompiliert, da müssten wir uns erst mal einarbeiten.

Der lighttpd + php ist aber selbst kompiliert, und auch die modernere Variante. Diese Fehlermeldung, die Du hast, hatte auch schon jemand anders. Vielleicht ist das Problem doch noch im lighttpd oder der Konfiguration. ist PHP installiert und gestartet? Welche Forensoftware ist das?

Lasertechniker
Posts: 3
Joined: Thu Jun 19, 2008 9:29
Product(s): AMS150
Contact:

Re: THTTPD mit PHP Function mail()

Postby Lasertechniker » Mon Jun 23, 2008 22:20

Hallo,
die Foren-Soft ist von hier :
http://www.frank-karau.de/
Ich habe aber nicht die große Ahnung was ich in der lighttpd.conf noch einstellen muß,
aber die Foren-Soft läuft garnicht erst an.
Grüße
Udo

Lasertechniker
Posts: 3
Joined: Thu Jun 19, 2008 9:29
Product(s): AMS150
Contact:

Re: THTTPD mit PHP Function mail()

Postby Lasertechniker » Fri Jun 27, 2008 13:58

Hallo,
so bin jetzt auf phpBB umgestiegen und was soll ich sagen?
Es läuft !!
Grüße

matze
Posts: 68
Joined: Wed Sep 19, 2007 14:56
Product(s): AMP 150 1.03.28eu

Re: THTTPD mit PHP Function mail()

Postby matze » Mon Jun 30, 2008 19:57

Hi,

hast du dafür jetzt thttpd und /mnt/.zap/web benutzt? Oder lighttpd und /mnt/Web (das wäre der zu bevorzugendene/dafür vorgesehene Weg).

Habe es übrigens auch mit lighttpd ausprobiert, habe da den HTTP Fehler 500

Es kann sein, dass unser PHP 5.2.6 nicht den Systemanforderungen des/der Board-Anwendung(en) genügt. Bei der Kompilierung musste auf Einiges verzichtet werden. Wie PHP kompiliert wurde, zeigt es dir, wenn du eine index.php nach /mnt/Web legst, die bspw. Folgendes enthält:

Code: Select all

<?php phpinfo() ?>


im Log steht

... das ist offenbar das lighttp log. Was steht denn in php_error.log, wenn du die Datei aufrufst, die nicht funktioniert?

Grüße,
Matze


Return to “Hints, FAQ”

Who is online

Users browsing this forum: No registered users and 1 guest

cron