eSATA Platte wird beim Anschluss gelöscht

GRUNDLAGEN

Moderator: ModTeam

Do_Checkor
Posts: 52
Joined: Mon Mar 02, 2009 20:08
Product(s): AMS150 (LCS8311) - 1.5 TB Seagate HDD
AMS150 (LCS8311) - 1 TB Seagate HDD
JCP eSATA+USB2 QuickSwap external - 1.5 TB Seagate HDD
TrekStor 2.5" USB2 HDD - 500 GB Fujitsu HDD

eSATA Platte wird beim Anschluss gelöscht

Postby Do_Checkor » Tue Jan 04, 2011 22:37

Moinsen!

Ich habe ein merkwürdiges Problem:

Wenn ich meine eSATA Platte welche ich ausschließlich zum backuppen nutze anschließe und das NAS starte kann ich im WebIF zuschauen wie der Füllstand der Platte (unter Status) immer weniger wird bis sie am Ende leer ist.

Ich dachte es wäre im Zusammenhang mit dem BackUpButton, aber eben sah ich weil ich was nachsehen wollte daß es auch ohne Betätigung des Buttons passiert.

Leider habe ich keine Ahnung von Linux um nachvollziehen zu können wieso das passiert.

Ich habe ein LCS8311

Habt Ihr ne Ahnung woran das liegen könnte?


NExt FW-Ext base:
start stop restart

NExtFW - base

version: 2.21.04
for LCS-8311
details

NExt FW-Ext base
created: Sun May 10 17:36:17 UTC 2009
by lochness

installed


addons
webadmin readme

version: 3.0.0
for AMS and SBLAN2
details

NExt-Addon tobi's famous php web-if
created: Tue Apr 7 05:28:53 UTC 2009
by tobitobsen

running



mc readme

version: 1.03
for AMS and SBLAN2
details

NExt-Addon Midnight Commander 4.1.40-pre9
created: Wed Apr 1 20:13:20 UTC 2009
by Brevheart

stopped




telnetd readme

version: 1.02
for AMS and SBLAN2
details

NExt-Addon telnetd
created: Wed Apr 1 20:11:40 UTC 2009
by lochness

running



backupbutton readme

version: 1.01
for AMS
details

NExt-Addon Backup Button Script
created: Thu May 14 19:51:35 UTC 2009
by lochness

running




tools readme

version: 1.00
for AMS and SBLAN2
details

NExt-Addon Tools
created: Sat Apr 11 07:11:36 UTC 2009
by Brevheart

running



webifmod readme

version: 0.98
for AMS and SBLAN2
details

NExt-Addon Do_Checkor's web interface mod
created: Wed Apr 22 22:14:25 UTC 2009
by Do_Checkor

running




php readme

version: 5.2.6a
for AMS and SBLAN2
details

NExt-Addon php 5.2.6 with mysql4 support
created: Sun Apr 5 06:35:44 UTC 2009
by Brevheart

running



lighttpd readme

version: 1.4.20
for AMS and SBLAN2
details

NExt-Addon lighttpd (1.4.20)
created: Fri Apr 10 14:22:49 UTC 2009
by Brevheart

running




streamripper readme

version: 1.63b
for AMS and SBLAN2
details

NExt-FW Add-On streamripper
created: Tue Jun 23 01:58:18 2009
by iwan

stopped



next-nav readme

version: 0.9
for AMS and SBLAN2
details

Navigation Framework for NExt-FW
created: Tue Jun 23 01:48:53 2009
by iwan75@gmx.net

standby



version: 2.2.1
code by tobitobsen | using phpsysinfo and Xajax | version 2.2.1 changes by lochness

User avatar
lochness
Posts: 3224
Joined: Sat Feb 04, 2006 20:42
Product(s): Myrica TV P42-2H
AMC 570 SAT (3.2.419 + VZD2)
AMC 370 SAT (1.6.115+VZD2)
AMP 150 (1.03.28eu)
3 x AMS 150 (V2.00 + NExt V2.0.06)
SBLAN2 R1.0 (V2.00 + NExt V2.0.06)
SBLAN2 R1.1 (V2.00 + NExt V2.0.06)
Storagebird DUO 35-LR (V1.03)
SB-L V1 (80GB, NetHDD007-0802)
Celvin Q800 4x2TB
Celvin Q700 2x1TB
Celvin Q600 1x2TB
Location: Bad Lippspringe

Re: eSATA Platte wird beim Anschluss gelöscht

Postby lochness » Tue Jan 04, 2011 23:52

Ja und nein :) .
Ich kenne eine Stelle im Code, die uns schon suspekt ist, seit wir sie gesehen haben. Ich meine, das Problem ist auch schon mal aufgetreten, leider ließ es sich bisher nicht richtig greifen. DIe Stelle ist in /etc/rc.d/network wie folgt:

Code: Select all

[ `grep "Vendor: ATA" /proc/scsi/scsi -c` -eq "2" ] && {
...   
} || rm -rf /mnt/esata_disk >/dev/null 2>&1

Ich vermute mal, es handelt sich bei Dir auch um diesen Stelle. Also muss die Ausgabe von /proc/scsi/scsi bei Dir irgendwie merkwürdig sein und die Platte gemountet sein (sonst würden Deine Daten nicht gelöscht werden, wenn die Platte nicht eingehängt wäre).
Das Problem müsste eigentlich, wenn, dann auf allen baugleichen Geräten auftreten, also auch auf dem AMS.
Ich nehme mal an es ist nicht beabsichtigt gewesen, hier echte Daten zu löschen, vielleicht wollte man nur den Mountpoint entfernen, das müsste man sich noch mal genau ansehen. Das network-Script liegt aber im Flash, daher ist eine Änderung ohne FW-Modifikation so einfach nicht möglich.
Wäre schön, wenn wir mal auf Dein NAS schauen könnten, woran es liegen könnte. Hast Du vielleicht noch andere Geräte dran?

Do_Checkor
Posts: 52
Joined: Mon Mar 02, 2009 20:08
Product(s): AMS150 (LCS8311) - 1.5 TB Seagate HDD
AMS150 (LCS8311) - 1 TB Seagate HDD
JCP eSATA+USB2 QuickSwap external - 1.5 TB Seagate HDD
TrekStor 2.5" USB2 HDD - 500 GB Fujitsu HDD

Re: eSATA Platte wird beim Anschluss gelöscht

Postby Do_Checkor » Wed Jan 05, 2011 23:12

Hmm....

Derzeit hab ich 1.5 TB - davon ~1.3 TB belegt. Die Backup-Platte entsprechend (im Idealfall) genau so.

Die Backup-Platte ist in EXT3 formatiert. Ich sichere in den Root - also eben nicht in ein Unterverzeichnis. Sinn: Im Falle eines Plattendefekts will ich einfach die Platte austauschen können und fertig. Dazu habe ich auch die Swap-Partition auf die Backup-Platte kopiert. Hab ich auch schon mal getestet - klappte einwandfrei...

Im Prinzip würde ich meine Backups eh lieber über USB machen als über eSATA.
Das dauert vielleicht länger, aber ich muss dann das NAS nicht zwei mal neu starten - und wenn es erst einmal sync ist, passt das dann schon...

Problem HIER: Die Platte taucht irgendwie im WebIF auf, wird also scheinbar nicht gemountet. Die USB-LED leuchtet, aber auch im NEXT FW Interface unter System Information sehe ich sie unten nicht. Meine externe FAT32 - 500GB - Platte wird hingegen problemlos gemountet...

Zu Deiner Frage: Im Normalfall ist kein anderes Gerät angeschlossen - also keine Platte oder USB-Stick.

Offtopic:
Ein Upgrade wird bald nötig - mein Netzteil hat die Grätsche gemacht und ich nutze nun schon das Ersatznetzteil vom Ersatzgerät. Damit ist meine Redundanz hinüber (biete jedoch schon hin und wieder bei ebay). Auch brauche ich bald mehr Platz. Frag mich also ob ich auf ein anderes Gerät umsteigen sollte - bei Tips bin ich also offen! Nicht zuletzt weil ich auch diverse Probleme mit der Kiste hab (hin und wieder stürzt die Kiste einfach ab und rebootet mit Werkseinstellungen; Jumboframes eingeschaltet lässt die Kiste einfrieren an einem Switch der keine Jumboframes kann; beim kopieren großer Dateien friert das Teil sporadisch ein; diverse andere Ungereimtheiten; ich hab wenig Vertrauen zur Redundanz; ich glaub ich hab eine Linuxallergie :-D )

Do_Checkor
Posts: 52
Joined: Mon Mar 02, 2009 20:08
Product(s): AMS150 (LCS8311) - 1.5 TB Seagate HDD
AMS150 (LCS8311) - 1 TB Seagate HDD
JCP eSATA+USB2 QuickSwap external - 1.5 TB Seagate HDD
TrekStor 2.5" USB2 HDD - 500 GB Fujitsu HDD

Re: eSATA Platte wird beim Anschluss gelöscht

Postby Do_Checkor » Mon Jan 17, 2011 0:17

Mal ein kleines Update meinerseits zum Thema:

Ich hab mit Nessy ein paar Sachen durchgesprochen dazu und mir wurde auch mehr als ein guter Tip zur Lösung meiner Probleme genannt.

Danke Nessy dafür!

Leider ist die Festplatte in meinem NAS mir nun (Murphy's Law at it's best) mit Getöse in einem Headcrash um die Ohren geflogen und ich musste meine Backup-Platte (leider mit immer noch unvollständigem Backup) nun dafür nutzen um meine Daten unter Kontrolle zu bekommen. Ich werde die Ideen von Nessy nun die kommende Woche, nachdem ich eine neue Platte für Backups gekauft habe, versuchen :-)

BTW - so weit ich das verstanden habe hat das ja sonst noch Niemand hinbekommen bzw. es wird allgemein gesagt es geht nicht:

Eine 2 TB Festplatte im AMS 150 scheint nicht gänzlich unmöglich zu sein - zumindest rennt das bei mir nun so - oder habe ich nur etwas falsch verstanden oder wie?

User avatar
Brevheart
Posts: 461
Joined: Wed Feb 21, 2007 9:23
Product(s): Synology DS211j

Re: eSATA Platte wird beim Anschluss gelöscht

Postby Brevheart » Mon Jan 17, 2011 1:10

Ich glaube ich muß nix mehr zu diesem Thema sagen! Nochmal kurz angemerkt: ich habe ein stabilen Betrieb mit 2 TB Festplatten nicht hinbekommen! Partitioniert in 2 X 1 TB , kein Problem! Aber vielleicht läuft es ja bei dir besser.

Gruß Brevheart

Do_Checkor
Posts: 52
Joined: Mon Mar 02, 2009 20:08
Product(s): AMS150 (LCS8311) - 1.5 TB Seagate HDD
AMS150 (LCS8311) - 1 TB Seagate HDD
JCP eSATA+USB2 QuickSwap external - 1.5 TB Seagate HDD
TrekStor 2.5" USB2 HDD - 500 GB Fujitsu HDD

Re: eSATA Platte wird beim Anschluss gelöscht

Postby Do_Checkor » Mon Jan 17, 2011 17:02

Brevheart wrote:Ich glaube ich muß nix mehr zu diesem Thema sagen! Nochmal kurz angemerkt: ich habe ein stabilen Betrieb mit 2 TB Festplatten nicht hinbekommen! Partitioniert in 2 X 1 TB , kein Problem! Aber vielleicht läuft es ja bei dir besser.


"Müssen" nicht - aber Deine Tips und Meinungen sind mir mehr als willkommen!

Wenn Du sagst "stabilen Betrieb" - wie hat sich denn ein "instabiler Betrieb" dargestellt? Würde ja gern noch testen ob das bei mir nun stabil ist oder nicht - augenscheinlich ist es das - aber nach 2 Tagen kann ich natürlich noch kein Fazit ziehen. Bevor ich mir nun eine weitere 2 TB Platte kaufe...

User avatar
Brevheart
Posts: 461
Joined: Wed Feb 21, 2007 9:23
Product(s): Synology DS211j

Re: eSATA Platte wird beim Anschluss gelöscht

Postby Brevheart » Mon Jan 17, 2011 19:44

Siehe bitte hier > http://forum.ts.fujitsu.com/digitalhome/viewtopic.php?f=41&t=8626&p=52915&hilit=2TB#p52915, einen stabilen Betrieb (interne Festplatte!!!) hast du auf jedenfall mit einer 1 TB Festplatte!

G. Brevheart

StN
Posts: 103
Joined: Fri Jun 26, 2009 10:27
Product(s): 2 x AMS150 500gb Next v2 - und mit den meisten Extensions. Danke fürs Entwickeln!
Und ganz flott: Seagate NAS110 Black Armor 1TB

Re: eSATA Platte wird beim Anschluss gelöscht

Postby StN » Wed Jan 19, 2011 1:54

Ich wollte nur erwähnen, dass Jockel auf das Problem mit dem unfreiwilligen Formatieren schon mal aufmerksam gemacht hat.
viewtopic.php?f=40&t=8131

User avatar
lochness
Posts: 3224
Joined: Sat Feb 04, 2006 20:42
Product(s): Myrica TV P42-2H
AMC 570 SAT (3.2.419 + VZD2)
AMC 370 SAT (1.6.115+VZD2)
AMP 150 (1.03.28eu)
3 x AMS 150 (V2.00 + NExt V2.0.06)
SBLAN2 R1.0 (V2.00 + NExt V2.0.06)
SBLAN2 R1.1 (V2.00 + NExt V2.0.06)
Storagebird DUO 35-LR (V1.03)
SB-L V1 (80GB, NetHDD007-0802)
Celvin Q800 4x2TB
Celvin Q700 2x1TB
Celvin Q600 1x2TB
Location: Bad Lippspringe

Re: eSATA Platte wird beim Anschluss gelöscht

Postby lochness » Wed Jan 19, 2011 7:16

StN wrote:Ich wollte nur erwähnen, dass Jockel auf das Problem mit dem unfreiwilligen Formatieren schon mal aufmerksam gemacht hat.
viewtopic.php?f=40&t=8131
Formatieren? Oder Löschen? (Kleiner Unterschied, wenn auch mit ähnlichem Ergebnis...)

StN
Posts: 103
Joined: Fri Jun 26, 2009 10:27
Product(s): 2 x AMS150 500gb Next v2 - und mit den meisten Extensions. Danke fürs Entwickeln!
Und ganz flott: Seagate NAS110 Black Armor 1TB

Re: eSATA Platte wird beim Anschluss gelöscht

Postby StN » Thu Jan 20, 2011 11:35

Ja, nicht formatieren, sondern mit rm -rf.
Wäre noch interessant zu lesen, ob esata-Transfer bei anderen auch mit
Jockel007 wrote:4MB/s und 100%CPU-Last
läuft.


Return to “Basics”

Who is online

Users browsing this forum: No registered users and 2 guests