HowTo: NExtFW-Paket mysql auf AMS/SBLAN2

TIPPS UND TRICKS, FAQ

Moderator: ModTeam

Deine Meinung zum NExt Paket mysql

Ich setze mysqlheute ein
8
89%
Ich werde es installieren, wenn die Version nicht mehr Beta ist
0
No votes
Momentan brauche ich mysql nicht, vielleicht später mal
1
11%
Ich habe kein Interesse an mysql
0
No votes
Ich werde keine modifizierten Firmware-Extensions einsetzen
0
No votes
 
Total votes: 9

User avatar
lochness
Posts: 3224
Joined: Sat Feb 04, 2006 20:42
Product(s): Myrica TV P42-2H
AMC 570 SAT (3.2.419 + VZD2)
AMC 370 SAT (1.6.115+VZD2)
AMP 150 (1.03.28eu)
3 x AMS 150 (V2.00 + NExt V2.0.06)
SBLAN2 R1.0 (V2.00 + NExt V2.0.06)
SBLAN2 R1.1 (V2.00 + NExt V2.0.06)
Storagebird DUO 35-LR (V1.03)
SB-L V1 (80GB, NetHDD007-0802)
Celvin Q800 4x2TB
Celvin Q700 2x1TB
Celvin Q600 1x2TB
Location: Bad Lippspringe

HowTo: NExtFW-Paket mysql auf AMS/SBLAN2

Postby lochness » Thu Feb 26, 2009 7:48

==================================================================================
Download: http://mai-computerhilfe.de/NExt/Addons/
Aktuelles Paket: NEXT_mysql--4.1.20--FSC_231.tgz-FSC_222.tgz
Aktuelles Readme (EN): NEXT_mysql--4.1.20--readme.txt
Aktuelles Readme (DE): NEXT_mysql--4.1.20--readme_de.txt

==================================================================================

Diese Software ist ausschließlich dazu bestimmt, mit den "NExt" Firmware Extensions für AMS150 und kompatible NAS Geräte genutzt zu werden.

WICHTIG:
Um dieses Paket nutzen zu können, muss vorher das "NExtFW Base" Paket installiert werden.

INSTALLATION DES PAKETES:
Das Paket kann über das Admin-GUI des Gerätes installiert werden ("Wartung" - "Firmware-Erweiterungen laden") / ("Maintenance" - load firmware extensions") oder über ein Netzwerklaufwerk. Das Admin-GUI erreichen Sie unter http://<NAME_DES_GERÄTES> oder http://<IP_ADRESSE_DES_GERÄTES>. Informationen zur Version des Paketes erhalten Sie auf der "NExtFW" Statusseite. Diese erreichen Sie im Admin-GUI, nachdem Sie das "NextFW Base" Paket installiert haben. Alternativ können Sie auch das NEXT_webadmin Paket installieren, das mehr Funktionalität bietet.

WICHTIG: Bitte beachten Sie, dass eine Installation der original Firmware Extensions die "NExt" Firmware Extensions nicht vollständig deinstalliert. Bitte installieren Sie zum Entfernen der Extensions das "NExtFW cleanup" Paket, welches die Extensions vollständig löscht oder formatieren Sie die Festplatte. (!!! dabei gehen alle Daten verloren !!!)
Einzelne Pakete können über das NEXT_webadmin Paket oder per Kommandozeile deinstalliert werden.

PAKETINHALT:
Diese Erweiterung installiert mySQL auf dem Gerät.
Des weiteren wird ein neuer Nutzer auf dem Gerät angelegt.
Name:"mysql"
Konfigurationsdatei: /mnt/.zap/opt/mysql/my.cnf

ÄNDERUNGEN:
4.1.20:
- Änderungen in den Readme Dateien
- Versionsnummer auf Final geändert
- Das preremove Script löscht jetzt den Ordner /mnt/.zap/opt/mysql nicht mehr vollständig. Dadurch bleiben die Datenbanken unter
/mnt/.zap/opt/mysql/data erhalten.
4.1.20B3: (dritte Beta)
- proftpd Datenbank wieder entfernt, diese muss Bestandteil des proftpd Pakets werden
- Shared Library Konflikte mit anderen Paketen behoben, gemeinsam genutzte Libraries in die NExt Base verschoben
- Geändertes preremove Script (angepasst an neue Pfade und Libraries)
- Geändertes Start-Script (angepasst an neue Pfade und Libraries)
4.1.20B2 (zweite Beta)
- proftpd Datenbank mit dem Nutzer „proftpd_admin“ und dem Passwort ams150
hinzugefügt
- Geändertes preremove Script
4.1.20B1:
- erste Version (Beta)

VORAUSSETZUNGEN:
- NExt base 1.0.03 / 2.0.03 oder neuer
- Um mySQL mit lighttpd und php nutzen zu können, müssen folgende NExt Addons installiert sein:
lighttpd 1.4.20 & php 5.2.6 (Pakete ab 11/08 oder neuer)
- Wer diese Korrektur einsetzt, damit die Datenbanken unter /mnt/.zap/opt/mysql/data bei späterem Löschen erhalten bleiben und aktuell die Version 4.1.20B3 installiert hat, sollte das alte Paket ausnahmsweise nicht vorher deinstallieren, sondern überinstallieren. Vorher sollte mysql aber korrekt gestoppt werden (per telnet/ssh/webadmin).

PROBLEME UND EINSCHRÄNKUNGEN:
- Die Datenbanken unter /mnt/.zap/opt/mysql/data werden bei der Deinstallation des Paketes nicht mehr mit gelöscht, sie müssen ggf. manuell gelöscht werden wenn sie nicht mehr benötigt werden.
- Bitte Deinstallieren Sie das Paket mysql4thttpd vor der Installation von NEXT_mysql. Es kann jeweils nur ein mySQL Paket iInstalliert sein.
- Bitte beachten, der erste Start und weitere Starts unterscheiden sich.
Bitte editieren Sie das Startscript: /mnt/.zap/etc/rc.d/mysql.sh
und beachten Sie den folgenden Code:

# very important!
# you have to connect from an external mysql command line
# in order to change the mysql user rights!
# for first start use this:
SKIP_OPTION="--skip-grant-tables"
MYSQL_USER=amsadmin
# for all other starts, use this:
#SKIP_OPTION=""
#MYSQL_USER=mysql
- Hinweis: Der lokale (unix domain) Socket ist auf /tmp/mysql.sock gesetzt. Dies ist auch in php.ini konfiguriert, oder der Port 3306 kann auch lokal verwendet werden.

Diese Software wird in der vorliegenden Form, ohne Gewähr auf Funktion, bereitgestellt. Für eventuelle Schäden, die durch die Benutzung der Erweiterungen entstehen können, können wir nicht haftbar gemacht werden. Die Benutzung der Software geschieht auf eigenes Risiko.

Viel Spaß,
Brevheart und das ganze NExtFW Team

==================================================================================

This software is intended to be used with the "NExt" Firmware Extensions for AMS150 and compatible NAS devices only.

IMPORTANT:
To use this package you will need to install the NExtFW base package first!

HOW TO INSTALL THIS PACKAGE:
The package can be installed via the Admin-GUI of the device ("Maintenance" - "load firmware extensions") or via network share. You can reach the Admin-GUI at http://<NAME_OF_THE_DEVICE> or http://<IP_ADDRESS_OF_THE_DEVICE>. Version information for this package is displayed via the "NExtFW" status page which you can reach via Admin-GUI right after you have installed the base package. Alternatively, you can install the NEXT_webadmin package with more functionality.

IMPORTANT: Please note that installing the original Firmware Extensions will not automatically deinstall the "NExt" Firmware Extensions completely. Please install the NExtFW cleanup package provided by NExt or format the hard disk (loosing all data!) to get rid of the Firmware Extensions at all. Single packages can be deinstalled via the NEXT_webadmin package or via command line.

PACKAGE CONTENTS:
This addon installs mysql on the device.
It also adds a new user account "mysql" to the device.
Config file: /mnt/.zap/opt/mysql/my.cnf

CHANGES:
4.1.20:
- changes in readme files
- changed version number to final
- The preremove script no longer deletes the folder /mnt/.zap/opt/mysql completely. The databases below /mnt/.zap/opt/mysql/data are therefore preserved.
4.1.20B3: (third beta)
- removed proftpd database, must be part of proftpd package
- fixed shared library conflicts with other packages, common shared libraries moved to NExt base
- changed preremove script (adapted to new paths and libraries)
- changed start script (adapted to new paths and libraries)
4.1.20B2: (second beta)
- added proftpd database with proftpd_admin user with password ams150
- changed preremove script
4.1.20B1:
- first version (beta)

PREREQUISITES:
- NExt Base 1.0.03 / 2.0.03 or newer
- To use mysql with lighttpd and php, you require the NExt Addons lighttpd 1.4.20 & php 5.2.6 (packages as of 11/08 or newer)
- If this new corrected version is installed because the databases below /mnt/.zap/opt/mysql/data should be retained during a later deinstallation and the version 4.1.20B3 is currently installed, the old package should not be deinstalled exceptionally, but an overinstallation should be done. Before, mysql should be stopped correctly (via telnet/ssh/webadmin).

ISSUES AND RESTRICTIONS:
- Databases below the program folder /mnt/.zap/opt/mysql/data are no longer removed during deinstallation, please delete them manually if you no longer need them.
- Please deinstall the package mysql4thttpd before using NEXT_mysql. You can only have one mysql package installed at a time.
- mysql needs more attention, first start and furhter starts are different
Please edit the start script /mnt/.zap/etc/rc.d/mysql.sh and look for the
following code:
# very important!
# you have to connect from an external mysql command line
# in order to change the mysql user rights!
# for first start use this:
SKIP_OPTION="--skip-grant-tables"
MYSQL_USER=amsadmin
# for all other starts, use this:
#SKIP_OPTION=""
#MYSQL_USER=mysql
- Note: the local (unix domain) socket is set to /tmp/mysql.sock
This is configured in php.ini, or the port 3306 can be used also locally.

This software is provided as is with no warranty of functionality. We cannot be held responsible for any damage that may occur after installing this extension.
You use this Software at your own risk.

Have fun,
Brevheart and the NExtFW team
Last edited by lochness on Tue Jul 12, 2011 6:47, edited 5 times in total.

User avatar
lochness
Posts: 3224
Joined: Sat Feb 04, 2006 20:42
Product(s): Myrica TV P42-2H
AMC 570 SAT (3.2.419 + VZD2)
AMC 370 SAT (1.6.115+VZD2)
AMP 150 (1.03.28eu)
3 x AMS 150 (V2.00 + NExt V2.0.06)
SBLAN2 R1.0 (V2.00 + NExt V2.0.06)
SBLAN2 R1.1 (V2.00 + NExt V2.0.06)
Storagebird DUO 35-LR (V1.03)
SB-L V1 (80GB, NetHDD007-0802)
Celvin Q800 4x2TB
Celvin Q700 2x1TB
Celvin Q600 1x2TB
Location: Bad Lippspringe

Re: HowTo: NExtFW-Paket mysql (Beta) auf AMS/SBLAN2

Postby lochness » Thu Feb 26, 2009 7:49

Bitte unbedingt beachten, dass dafür die Base 03 notwendig ist, und dass alle alten Pakete vor dem Update auf Version 03 sauber deinstalliert werden müssen :!: Siehe Beschreibung der NExt Base.

User avatar
lochness
Posts: 3224
Joined: Sat Feb 04, 2006 20:42
Product(s): Myrica TV P42-2H
AMC 570 SAT (3.2.419 + VZD2)
AMC 370 SAT (1.6.115+VZD2)
AMP 150 (1.03.28eu)
3 x AMS 150 (V2.00 + NExt V2.0.06)
SBLAN2 R1.0 (V2.00 + NExt V2.0.06)
SBLAN2 R1.1 (V2.00 + NExt V2.0.06)
Storagebird DUO 35-LR (V1.03)
SB-L V1 (80GB, NetHDD007-0802)
Celvin Q800 4x2TB
Celvin Q700 2x1TB
Celvin Q600 1x2TB
Location: Bad Lippspringe

Re: HowTo: NExtFW-Paket mysql auf AMS/SBLAN2

Postby lochness » Fri Apr 10, 2009 16:31

Update von mysql. Final Version 4.1.20.
Viel Spaß damit und frohe Ostern wünscht das NExt Team :D ...

OnkelGomez
Posts: 14
Joined: Tue Aug 18, 2009 0:06
Product(s): SBLAN 2 V1.1
-NExt FW-Ext base V2.0.04
-NExt FW Addon lighttpd V1.4.20
-NExt FW Addon php V5.2.6b
-NExt FW Addon mysql V4.1.20

Re: HowTo: NExtFW-Paket mysql auf AMS/SBLAN2

Postby OnkelGomez » Tue Aug 25, 2009 11:52

Hallo Allerseits!

Ich wollte mal Fragen ob bei mysql ein Versionssprung geplant ist? von V4 auf V5.

Die Intension meiner Frage liegt darin, ich werde wieder in ein Browsergame einsteigen und es gibt sogenannte Koordinaten DBs in die man das Spielfeld einlesen, also alle Spieler mit ihren Planeten, Clanzugehörigkeiten usw. Die beste DB ist allerdings erst voll Funktionsfähig unter mysql5 weil stored procedures/functions erst ab mysql 5 zur verfügung gestellt werden.

Vllt. gibt es ja mehr Leute die sich mysql 5 wünschen oder haben wollen.

MfG
OnkelGomez

User avatar
lochness
Posts: 3224
Joined: Sat Feb 04, 2006 20:42
Product(s): Myrica TV P42-2H
AMC 570 SAT (3.2.419 + VZD2)
AMC 370 SAT (1.6.115+VZD2)
AMP 150 (1.03.28eu)
3 x AMS 150 (V2.00 + NExt V2.0.06)
SBLAN2 R1.0 (V2.00 + NExt V2.0.06)
SBLAN2 R1.1 (V2.00 + NExt V2.0.06)
Storagebird DUO 35-LR (V1.03)
SB-L V1 (80GB, NetHDD007-0802)
Celvin Q800 4x2TB
Celvin Q700 2x1TB
Celvin Q600 1x2TB
Location: Bad Lippspringe

Re: HowTo: NExtFW-Paket mysql auf AMS/SBLAN2

Postby lochness » Wed Aug 26, 2009 6:51

Also, wir hatten bisher davon abgesehen, und zwar weil es große Abhängigkeiten gibt.
Für mysql5 müssen wir nicht nur das mysql Paket, sondern (mindestens) auch lighttpd, php, webadmin und mediatomb austauschen und auch alles noch mal durchtesten. Ob man die alten Datenbanken behalten kann, und wie man updatet, müssen wir auch testen.
Und, wir werden dann nicht beides parallel pflegen, d.h. wenn es mysql5 gäbe, dann sind keine Updates mehr geplant für die Pakete mit mysql4.

Aber, warum nicht, wenn der Bedarf da ist. Also, wer möchte auch mysql5 haben? Wer würde an einem Betatest teilnehmen? Oder, wer braucht zwingend das alte mysql4?

OnkelGomez
Posts: 14
Joined: Tue Aug 18, 2009 0:06
Product(s): SBLAN 2 V1.1
-NExt FW-Ext base V2.0.04
-NExt FW Addon lighttpd V1.4.20
-NExt FW Addon php V5.2.6b
-NExt FW Addon mysql V4.1.20

Re: HowTo: NExtFW-Paket mysql auf AMS/SBLAN2

Postby OnkelGomez » Wed Aug 26, 2009 13:52

Hallo lochness,

da ich den wunsch nach mysql5 ausgesprochen habe bin ich natürlich gerne bereit als versuchskaninchen meinen kopf hinzuhalten ;)

MfG
OnkelGomez

morpheus1412
Posts: 1
Joined: Wed Nov 11, 2009 7:13
Product(s): AMS 150

Re: HowTo: NExtFW-Paket mysql auf AMS/SBLAN2

Postby morpheus1412 » Sat Feb 27, 2010 11:37

Hallo @ all.

Also erstmal Besten Dank für eure saubere Arbeit. Habe nun endlich auch Joomla 1.5 auf mein AMS 150 zulaufen. Bin total happy.
Leider läuft der CBE nur unter mysql 5. Darum wünsche ich mir auch mysql 5.

BESTEN DANK AN ALLE


Return to “Hints, FAQ”

Who is online

Users browsing this forum: No registered users and 2 guests