Page 1 of 1

HowTo: NExtFW-Paket Python auf AMS/SBLAN2

Posted: Mon Oct 06, 2008 22:32
by lochness
==================================================================================
Download: http://mai-computerhilfe.de/NExt/Addons/
Aktuelles Paket: NEXT_python--2.6.1b--FSC_231.tgz-FSC_222.tgz
Aktuelles Readme (EN): NEXT_python---2.6.1b--readme.txt
Aktuelles Readme (DE): NEXT_python---2.6.1b--readme_de.txt

==================================================================================

Diese Software ist ausschließlich dazu bestimmt, mit den "NExt" Firmware Extensions für AMS150 und kompatible NAS Geräte genutzt zu werden.

WICHTIG:
Um dieses Paket nutzen zu können, muss vorher das "NExtFW Base" Paket installiert werden.

INSTALLATION DES PAKETES:
Das Paket kann über das Admin-GUI des Gerätes installiert werden ("Wartung" - "Firmware-Erweiterungen laden") / ("Maintenance" - load firmware extensions") oder über ein Netzwerklaufwerk. Das Admin-GUI erreichen Sie unter http://<NAME_DES_GERÄTES> oder http://<IP_ADRESSE_DES_GERÄTES>. Informationen zur Version des Paketes erhalten Sie auf der "NExtFW" Statusseite. Diese erreichen Sie im Admin-GUI, nachdem Sie das "NextFW Base" Paket installiert haben.
Alternativ können Sie auch das NEXT_webadmin Paket installieren, das mehr Funktionalität bietet.

WICHTIG: Bitte beachten Sie, dass eine Installation der original Firmware Extensions die "NExt" Firmware Extensions nicht vollständig deinstalliert. Bitte installieren Sie zum Entfernen der Extensions das "NExtFW cleanup" Paket, welches die Extensions vollständig löscht oder formatieren Sie die Festplatte. (!!! dabei gehen alle Daten verloren !!!)
Einzelne Pakete können über das NEXT_webadmin Paket oder per Kommandozeile deinstalliert werden.

PAKETINHALT:
Diese Erweiterung installiert Python 2.6.1 auf dem Gerät.

Third Party Tools sind ebenfalls installiert:
yEnc 0.3 Module for Python, Cheetah 2.2.1, cElementTree 1.0.5, ElementTree 1.2.6, pyOpenSSL-0.7, pycrypto-2.3, flup 1.0.2, python-imaging-1.1.7, Django 1.2.3, libxml2-python-2.6.9

ÄNDERUNGEN:
- 2.6.1b:
Beaker-1.5.4 und Jinja2-2.5.5 hinzugefügt
- 2.6.1a:
python-imaging auf Version 1.1.7 upgedatet, libxml2-python-2.6.9 hinzugefügt, pyusb-1.0.0-a1 hinzugefügt, *.pyc und pyo Dateien entfernt
- 2.6.1:
Update auf neue Python version 2.6.1
pycurl-7.19.0, Django-1.2.3, flup 1.0.2, python-imaging-1.1.6 hinzugefügt
update pycrypto auf Version 2.3
- 2.4.6:
Update auf neue Python Version 2.4.6, Update Cheetah auf 2.2.1
- 0.96:
deutsches Readme, Änderungen in den Readme Dateien
- 0.97:
pycrypto 2.0.1 hinzugefügt
- 0.98:
Shared Library Konflikt mit anderen Paketen beseitigt
- 0.99:
erste Beta Version

VORAUSSETZUNGEN:
- NEXT_base 1.0.04 / 2.0.04 oder neuer

PROBLEME UND EINSCHRÄNKUNGEN:
- keine

Diese Software wird in der vorliegenden Form, ohne Gewähr auf Funktion, bereitgestellt. Für eventuelle Schäden, die durch die Benutzung der Erweiterungen entstehen können, können wir nicht haftbar gemacht werden. Die Benutzung der Software geschieht auf eigenes Risiko.

Have fun,
Brevheart und das NExtFW Team

==================================================================================

IMPORTANT:

This software is intended to be used with the "NExt" Firmware Extensions for AMS150 and compatible NAS devices only.

IMPORTANT:
To use this package you will need to install the NExtFW base package first!

HOW TO INSTALL THIS PACKAGE:
The package can be installed via the Admin-GUI of the device ("Maintenance" - "load firmware extensions") or via network share. You can reach the Admin-GUI at http://<NAME_OF_THE_DEVICE> or http://<IP_ADDRESS_OF_THE_DEVICE>. Version information for this package is displayed via the "NExtFW" status page which you can reach via Admin-GUI right after you have installed the base package.
Alternatively, you can install the NEXT_webadmin package with more functionality.

IMPORTANT: Please note that installing the original Firmware Extensions will not automatically deinstall the "NExt" Firmware Extensions completely. Please install the NExtFW cleanup package provided by NExt or format the hard disk (loosing all data!) to get rid of the Firmware Extensions at all.
Single packages can be deinstalled via the NEXT_webadmin package or via command line.

PACKAGE CONTENTS:
This addon adds Python 2.6.1 to your device.

Third Party Tools installed:
yEnc 0.3 Module for Python, Cheetah 2.2.1, cElementTree 1.0.5, ElementTree 1.2.6, pyOpenSSL-0.7, pycrypto-2.3, flup 1.0.2,
python-imaging-1.1.7, Django 1.2.3, libxml2-python-2.6.9, pyusb-1.0.0-a1

CHANGES:
- 2.6.1b:
Beaker-1.5.4 and Jinja2-2.5.5 added
- 2.6.1a:
update python-imaging to version 1.1.7, libxml2-python-2.6.9 added,
pyusb-1.0.0-a1 added, *.pyc and *.pyo files cleaned
- 2.6.1:
update to new python version 2.6.1
pycurl-7.19.0, Django-1.2.3, flup 1.0.2, python-imaging-1.1.6 added
update pycrypto 2.3
- 2.4.6:
update to new python version 2.4.6, update Cheetah to 2.2.1
- 0.96:
german readme, changes to readme files
- 0.97:
added pycrypto 2.0.1
- 0.98:
fixed share library conflicts with other packages
- 0.99:
first beta version

PREREQUISITES:
- NEXT_base 1.0.04 / 2.0.04 or newer

ISSUES AND RESTRICTIONS:
- none

This software is provided as is with no warranty of functionality. We cannot be held responsible for any damage that may occur after installing this extension. You use this Software at your own risk.

Have fun,
Brevheart and the NExtFW team

Re: HowTo: NExtFW-Paket Python (Beta) auf AMS/SBLAN2

Posted: Mon Oct 06, 2008 22:45
by Brevheart
Platzhalter

Re: HowTo: NExtFW-Paket Python (Beta) auf AMS/SBLAN2

Posted: Sat Oct 11, 2008 11:50
by lochness
Und, noch mal eine Bitte in eigener Sache. Brevheart und ich arbeiten momentan recht viel an NExt, also daran, euch neue Funktionen zur Verfügung zu stellen und die gemeldeten Fehler zu finden. Es macht uns eine Menge Spaß, keine Frage, aber wir haben überhaupt kein Gefühl dafür, d.h. wie viele Benutzer wir haben und wie viele Geräte wir damit etwas "aufpeppen" können. Leider haben wir keinen Download-Zähler auf der Webseite. Daher werde ich mal Umfragen zu den Paketen ins Forum stellen. Unsere Bitte ist, dass jeder, der das Paket verwendet, dort mit abstimmt.

Und, während die Pakete im öffentlichen Beta-Status sind, möchten wir auch um Feedback der Beta-Tester hier im Thread bitten.

Re: HowTo: NExtFW-Paket Python (Beta) auf AMS/SBLAN2

Posted: Wed Feb 25, 2009 22:45
by lochness
Python 0.98 ist online.

Bitte unbedingt beachten, dass dafür die Base 03 notwendig ist, und dass alle alten Pakete vor dem Update auf Version 03 sauber deinstalliert werden müssen :!: Siehe Beschreibung der NExt Base.

Re: HowTo: NExtFW-Paket Python (Beta) auf AMS/SBLAN2

Posted: Sun Mar 08, 2009 13:02
by lochness
Python 0.97 ist online (noch mal der Hinweis, 0.97 ist neuer als 0.98, während des Betatests wird hier rückwärts gezählt).

Brevheart war so freundlich und hat pycrypt hinzugefügt, das Modul wird für das RSDM Paket benötigt.

Re: HowTo: NExtFW-Paket Python (Beta) auf AMS/SBLAN2

Posted: Fri Apr 10, 2009 17:35
by lochness
Python 0.96 ist online, aber es gibt keine funktionalen Änderungen gegenüber der Version 0.97. Es wurden nur Links und Texte im Readme geändert.

Re: HowTo: NExtFW-Paket Python auf AMS/SBLAN2

Posted: Sat Dec 19, 2009 22:46
by lochness
Brevheart war so freundlich und hat Python upgedatet auf Version 2.4.6. Download siehe erster Beitrag in diesem Thread.
Ich habe das Paket jetzt auch mal aus dem Beta-Status befreit.

Re: HowTo: NExtFW-Paket Python auf AMS/SBLAN2

Posted: Sat Nov 06, 2010 13:44
by lochness
Brevheart war so freundlich und hat Python upgedatet auf Version 2.6.1, dies ist Voraussetzung für Pyload.
Download siehe erster Beitrag in diesem Thread.

Re: HowTo: NExtFW-Paket Python auf AMS/SBLAN2

Posted: Mon Jan 10, 2011 23:28
by lochness
Brevheart war so freundlich und hat Python mit neuen Features ausgestattet, das damit eine bessere Unterstützung für pyload bietet. Es ist jetzt die Version 2.1.6a. Download und Readme siehe erster Beitrag in diesem Thread.

Re: HowTo: NExtFW-Paket Python auf AMS/SBLAN2

Posted: Sun Apr 10, 2011 13:21
by lochness
Python in der Version 2.1.6b ist fertig, siehe ganz oben. Diese Version wird für pyload ab Version 0.4.5 benötigt.
Bitte die Umfrage oben auch aktualisieren, es kann ja nicht sein, dass wir 7 pyload-User haben und nur 4 python-User :wink: ...