Page 4 of 5

Re: HowTo: Installation NExtFW-Pakete lighttpd+php auf AMS/SBLAN

Posted: Mon Jun 30, 2008 18:34
by A150TK
Hallo!
Ich bin noch ein von "den Alten". Skype habe ich auf meinem Laptop,- da kann mann ja auch Nachrichten direkt hin und herschicken.
Gruss!

Re: HowTo: Installation NExtFW-Pakete lighttpd+php auf AMS/SBLAN

Posted: Wed Jul 02, 2008 10:42
by A150TK
Hallo! Wollte ´mal nachfragen, wann´s weitergeht.
Gruesse aus dem Norden!

Re: HowTo: Installation NExtFW-Pakete lighttpd+php auf AMS/SBLAN

Posted: Wed Jul 02, 2008 19:12
by lochness
Ich bin zwar auch "alt", aber ich habe kein Skype :). Dafür aber Chat :wink:... Dachte, ich dürfte vielleicht wählen :wink:...

Re: HowTo: Installation NExtFW-Pakete lighttpd+php auf AMS/SBLAN

Posted: Fri Jul 04, 2008 11:56
by A150TK
lochness wrote:Ich bin zwar auch "alt", aber ich habe kein Skype :). Dafür aber Chat :wink:... Dachte, ich dürfte vielleicht wählen :wink:...

Hallo! Vielen Dank für die Antwort. Wann hätten Sie denn noch´mal Zeit wegen meiner 2 offenen Themen?
Danke und Gruss!

Re: HowTo: Installation NExtFW-Pakete lighttpd+php auf AMS/SBLAN

Posted: Wed Nov 26, 2008 22:11
by matze
Noch eine Bitte vom NExt Team. Bitte stimmt oben bei der Umfrage mit ab. Das wird uns helfen, die Prioritäten für euch passend zu setzen.

Re: HowTo: Installation NExtFW-Pakete lighttpd+php auf AMS/SBLAN

Posted: Sun Nov 30, 2008 23:54
by lochness
lighttpd und php wurden heute vorläufig vom Download Server zurückgezogen.
Grund ist, dass es einen neuen Schwung Pakete (lighttpd, mysql, php) im Betatest geben wird, der diesen alten Stand ablöst. Mehr dazu später, aber so wie es aussieht, werden viele bisher fehlende Funktionen jetzt mitgeliefert. Erste Tests waren sehr vielversprechend. Danke an Brevheart :D !!!

Re: HowTo: Installation NExtFW-Pakete lighttpd+php auf AMS/SBLAN

Posted: Sat Dec 06, 2008 21:08
by lochness
So, heute gibt es mal die Beta neue NExt-Addons zum Nikolaus, weil ihr alle so brav wart :mrgreen: ...

Es handelt sich um lighttpd, php und mysql in den Versionen:
NEXT_lighttpd--1.4.20B1--FSC_231.tgz-FSC_222.tgz
NEXT_php--5.2.6B1--FSC_231.tgz-FSC_222.tgz
NEXT_mysql--4.1.20B1--FSC_231.tgz-FSC_222.tgz

Die bisherigen Pakete
NEXT_lighttpd--1.4.19--FSC_231.tgz-FSC_222.tgz
NEXT_php--5.2.6--FSC_231.tgz-FSC_222.tgz
NEXT_thttpd--2.21b--FSC_231.tgz-FSC_222.tgz
NEXT_mysql4thttpd--4.1.22--FSC_231.tgz-FSC_222.tgz
entfallen. Sie sind hiermit abgekündigt, da sie in der Variante nicht weiterentwickelt werden. Die neuen Pakete sollten möglichst alle benötigten Funktionen bieten, dies sollte im Betatest überprüft werden. Ich möchte daher darum bitten, dass auch die (wenigen) Nutzer von thttpd und ggf. mysql4thttpd auf die neue Version umsteigen und beim Betatest mitmachen. Wer Hilfe braucht beim Umstieg, meldet sich bitte hier im Forum.

Wer am Betatest teilnehmen möchte, der muss die alten Pakete sauber deinstallieren (z.B. mit Hilfe des webadmin-Benutzerinterfaces) und die neuen Pakete installieren. (Leider deinstalliert sich thttpd nicht sauber und läßt den Ordner /mnt/.zap/opt/thttpd stehen, das kann man mit telnet-/ssh-Zugang bereinigen, sollte aber auch nicht weiter stören.)
lighttpd und php sind kompatibel zu den oben beschriebenen Paketen, es ist eine Weiterentwicklung mit mehr Funktionen, u.a. der mysql Unterstützung.

Die Beta gibt es wie immer bei mir, bitte schreibt mir PN.

Re: HowTo: Installation NExtFW-Pakete lighttpd+php auf AMS/SBLAN

Posted: Wed Feb 25, 2009 22:58
by Erazor_2001
Update:
Guten Morgen,
nachdem ich gestern Abend gesehen habe, dass die neuen Pakete da sind, habe ich nochmal alles mit den neuen Versionen installiert und siehe da, es geht !!! So nun kann ich mit dem lighttpd + php experimentieren.

Grüße,
Thorsten


Hallo Leute,
ich bin zwar schon seit längerem als Gast hier unterwegs und habe mir auch schon viele nützliche Hilfestellungen hier geholt - Dafür erst mal ein dickes DANKE :!: - aber nun habe ich folgendes Problem für das ich noch nirgends eine Antwort gefunden habe:
Ich habe NExtFW + telnet + lighttpd + php + webadmin installiert (+ noch ein paar andere Erweiterungen) aber ich bekomme es nicht hin, dass ein Seite mit php angezeigt wird. Webadmin zeigt mir auch brav alles als gestartet an. Wenn ich php_info.php aufrufe, wird auch soweit alles angezeigt. Versuche ich nun irgendeine Seite mit Port 4711 (habe das erst mal so gelassen) auf, kommt nix - kein Fehler aber auch keine Seite - einfach nichts :?
Jetzt muss ich noch dazu sagen, dass ich ein ziemlicher Anfänger im Linux, php und "Webserver im allgemeinen" bin.
Versionen lt. webadmin:
NExtFW Version: 2.0.02-TW
Addons
webadmin Version: 2.2.0
telnetd Version: 1.00
lighttpd Version: 1.4.19
php Version: 5.2.6

Wahrscheinlich ist es eine ganz simple Sache, aber ich zahne da schon seit Tagen dran und hoffe es kann mir von Euch jemand helfen.

Danke,
Thorsten

Re: HowTo: Installation NExtFW-Pakete lighttpd+php auf AMS/S

Posted: Thu Feb 26, 2009 7:55
by lochness
Die aktuellen Versionen zum Download sind hier:

==================================================================================
Download: http://mai-computerhilfe.de/NExt/Addons/
Aktuelles Paket: NEXT_php--5.2.6b--FSC_231.tgz-FSC_222.tgz
Aktuelles Readme (EN): NEXT_php--5.2.6b--readme.txt
Aktuelles Readme (DE): NEXT_php--5.2.6b--readme_de.txt
Aktuelles Paket: NEXT_lighttpd--1.4.20a--FSC_231.tgz-FSC_222.tgz
Aktuelles Readme (EN): NEXT_lighttpd--1.4.20a--readme.txt
Aktuelles Readme (DE): NEXT_lighttpd--1.4.20a--readme_de.txt

==================================================================================

Bitte unbedingt beachten, dass dafür die Base 03 notwendig ist, und dass alle alten Pakete vor dem Update auf Version 03 sauber deinstalliert werden müssen :!: Siehe Beschreibung der NExt Base.

Re: HowTo: Installation NExtFW-Pakete lighttpd+php auf AMS/SBLAN

Posted: Sun Mar 15, 2009 20:01
by lochness
Ich habe die Version des PHP-Paketes im oberen Beitrag auf Beta 3 geändert und die Version hochgeladen.
Es war eine Änderung notwendig für einige PHP-Pakete wie torrentflux, die die Include_Dateien im aktuellen Ordner erwarten.

Re: HowTo: Installation NExtFW-Pakete lighttpd+php auf AMS/SBLAN

Posted: Fri Apr 10, 2009 20:32
by lochness
So, lighttpd und php wurden jetzt als final Version hochgeladen.

Bei PHP hat sich gegenüber der alten Beta-Version 5.2.6B3 funktional nichts geändert.

lighttpd hat gegenüber der alten Beta-Version 1.4.20B3 folgende Änderungen:
1.4.20:
- Final Version
- Änderungen in den Readme-Dateien
- Installation geändert, auf dem LCS-8311 wird jetzt /mnt/WEB standardmäßig als Web-Ordner verwendet, auf anderen Geräten /mnt/Web. Der Ordner kann in der lighttpd Konfigurationsdatei geändert werden, wie beschrieben.

Re: HowTo: Installation NExtFW-Pakete lighttpd+php auf AMS/SBLAN

Posted: Sun Jun 07, 2009 18:41
by lochness
PHP 5.6.2b ist jetzt fertig.
Die Fehlermeldungen in der PHP Log Datei treten jetzt nicht mehr auf.
Und, es wurden die fehlenden Libs hinzugefügt, so dass z.B. jetzt auch die imap Funktionen gehen sollten.

Herzlichen Dank an Brevheart für die Änderung!

Re: HowTo: Installation NExtFW-Pakete lighttpd+php auf AMS/SBLAN

Posted: Thu Jun 11, 2009 13:18
by jazer
Servus,

erstmal vielen Dank an euch alle, welche diese NEXTFW Ext. entickelt bzw. protiert haben.

Ich hab momentan lighttpd+php am laufen. Da ich gerne mit sqlite arbeiten will, stellt sich die Frage ob es eine Portierung von V3 gibt. Die V2 ist momentan installiert (default).

Gruß,
jazer

Re: HowTo: Installation NExtFW-Pakete lighttpd+php auf AMS/SBLAN

Posted: Fri Jun 12, 2009 6:45
by Brevheart
Hi, die Portierung gibt es noch nicht, ob es sie geben wird kann ich noch nicht sagen! Wenn es die Zeit her gibt werden wir uns der Sache annehmen.

Gruß Brevheart

Re: HowTo: Installation NExtFW-Pakete lighttpd+php auf AMS/SBLAN

Posted: Thu Jun 18, 2009 0:48
by jazer
Servus,

danke erstmal für die Antwort. Ich hab gesehen dass es schon ein sqlite3 port für firefly gibt. d.h. ich hab den dort im Verzeichnis meines AMS150 gefunden.

Die Frage stellt sich mir, ob es eine Integrationsmöglichkeit mit dem sqlite3 aus dem firefly gibt. Das sollte wahrscheinlich kein Problem sein, da ich vermute "nur" ein paar Pfade anpassen muss. Liege ich da richtig? Wenn ja, kann mir jemand sagen wo ggf. diese Pfade liegen (config?)?.


Vielen Dank,
jazer

PS: Da ich aus der J2EE Ecke komme und keine Erfahrungen mit PHP direkt habe, wäre ein Tomcat/Jboss/Glassfish natürlich das "Beste" für mich. Aber ich vermute eine JVM zu portieren und dann auf dem AMS150 laufen zu lassen wäre ein "Killer" für den Server. Oder?