Offlinedateien/problem bei snychronisierung

GRUNDLAGEN

Moderator: ModTeam

rednaxela
Posts: 8
Joined: Sat Dec 29, 2007 12:10

Offlinedateien/problem bei snychronisierung

Postby rednaxela » Thu Feb 07, 2008 22:24

moin,

ich hab auf dem AMS150 einen Ordner, den ich auf meinem Laptop (Windows XP Prof.) als Netzlaufwerk verbunden hab und für Offlinedateien eingerichtet habe (Offline verfügbar machen).
Die Synchronisation klappt im Großen und Ganzen so einigermaßen. Bei manchen Dateien gab es Schiwerigkeiten mit den Zugriffsrechten, daher hab ich mit dem telnet-Zugriff aus den Firmware-Extensions mal den ganzen Ordner auf chmod 777 gesetzt. Seitdem gabs weniger Fehler bei der Synchronisierung. Allerdings verweigert der AMS bei allen neuen thumbs.db Dateien den Zugriff: "Offlinedateien: Der Zugriff aus Thumbs.db auf \amsxyz wurde verweigert."
Auch ein wiederholtes chmod -R 777 bringt nix. Woran kann das liegen?

Besten Dank, Alex

User avatar
lochness
Posts: 3224
Joined: Sat Feb 04, 2006 20:42
Product(s): Myrica TV P42-2H
AMC 570 SAT (3.2.419 + VZD2)
AMC 370 SAT (1.6.115+VZD2)
AMP 150 (1.03.28eu)
3 x AMS 150 (V2.00 + NExt V2.0.06)
SBLAN2 R1.0 (V2.00 + NExt V2.0.06)
SBLAN2 R1.1 (V2.00 + NExt V2.0.06)
Storagebird DUO 35-LR (V1.03)
SB-L V1 (80GB, NetHDD007-0802)
Celvin Q800 4x2TB
Celvin Q700 2x1TB
Celvin Q600 1x2TB
Location: Bad Lippspringe

Postby lochness » Thu Feb 07, 2008 22:31

Vielleicht liegt's am Hidden-Attribut? Welchen Eigentümer und welche Rechte hat die Datei auf dem AMS?
Welche Firmware hast Du auf dem AMS?
Hmm, müsste man mal nachtesten...

rednaxela
Posts: 8
Joined: Sat Dec 29, 2007 12:10

Postby rednaxela » Thu Feb 07, 2008 23:17

scheint damit zusammenzuzuhängen. Im Offlinemodus werden die thumbs.db als "versteckt" geführt (wobei die checkbox inaktiv ist, also nicht klickbar).
Im Onlinebetrieb ist die thumbs.db nicht hidden. besitzer ist root (Unix User oot). im reiter sicherheit gibts nur root und die gruppen Jeder und wheel. Mein Benutzer, der auch im Webinterface mit Vollzugriff eingetragen ist, taucht nicht auf?!
firmware beta 2.0 + extensions von zaphod mit telnet.

User avatar
lochness
Posts: 3224
Joined: Sat Feb 04, 2006 20:42
Product(s): Myrica TV P42-2H
AMC 570 SAT (3.2.419 + VZD2)
AMC 370 SAT (1.6.115+VZD2)
AMP 150 (1.03.28eu)
3 x AMS 150 (V2.00 + NExt V2.0.06)
SBLAN2 R1.0 (V2.00 + NExt V2.0.06)
SBLAN2 R1.1 (V2.00 + NExt V2.0.06)
Storagebird DUO 35-LR (V1.03)
SB-L V1 (80GB, NetHDD007-0802)
Celvin Q800 4x2TB
Celvin Q700 2x1TB
Celvin Q600 1x2TB
Location: Bad Lippspringe

Postby lochness » Thu Feb 07, 2008 23:22

Nun, die thumbs.db ist doch auf NTFS immer hidden. Nur, hidden wird doch auf dem AMS nicht unterstützt. Daher passt das doch, online = hidden und offline = nicht hidden. Nur, wie gewöhnt man ihm das ab? Musst Du denn überhaupt thumbs.db schreiben?
Wenn ich Zeit habe, kann ich mir das ja mal anschauen.
Das mit den Benutzern ist aber bestimmt normal, die Dateien gehören auf der Platte doch immer root, schau mal mit telnet drauf.

rednaxela
Posts: 8
Joined: Sat Dec 29, 2007 12:10

Postby rednaxela » Thu Feb 07, 2008 23:53

klar könnte ich das Speichern der Vorschau abschalten, aber ich find die schon sinnvoll :-)

mit wlechem kommando kann ich denn den Besitzer ausgeben? bzw. was sind eigentlich spalten 2-4 bei "ls -l"?

User avatar
lochness
Posts: 3224
Joined: Sat Feb 04, 2006 20:42
Product(s): Myrica TV P42-2H
AMC 570 SAT (3.2.419 + VZD2)
AMC 370 SAT (1.6.115+VZD2)
AMP 150 (1.03.28eu)
3 x AMS 150 (V2.00 + NExt V2.0.06)
SBLAN2 R1.0 (V2.00 + NExt V2.0.06)
SBLAN2 R1.1 (V2.00 + NExt V2.0.06)
Storagebird DUO 35-LR (V1.03)
SB-L V1 (80GB, NetHDD007-0802)
Celvin Q800 4x2TB
Celvin Q700 2x1TB
Celvin Q600 1x2TB
Location: Bad Lippspringe

Postby lochness » Thu Feb 07, 2008 23:58

Langsamer Rechner :wink:?
Die Spalten 3 und 4 bei "ls -l" sind der Besitzer und die Gruppe.
Mit der Busybox, die heute auf dem AMS ist, sieht man das aber leider nicht, sondern nur die Nummer.

rednaxela
Posts: 8
Joined: Sat Dec 29, 2007 12:10

Postby rednaxela » Sat Feb 09, 2008 13:34

ah :) hatte mir sowas schon gedacht...
maße dich nicht an, über die schnelligkeit meines core 2 duo zu spekulieren :D ich will aber trotzdem nicht auf die gespeicherten Vorschaubilder verzichten. Hängt wohl definitiv mit dem Hidden_Attribut zusammen. Behelf mir jetzt erstmal mit löschen vor dem Synchronisieren...


Return to “Basics”

Who is online

Users browsing this forum: No registered users and 1 guest

cron